Skip to content

← Actionable
Unratedamended

Cross-site Scripting Vulnerability in GraphQL Playground (distributed by Apollo Server)

GHSA-qm7x-rc44-rrqw

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (apollo-server 3.4.1, 2.25.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm apollo-server

    Affected
    >= 2.0.0, < 2.25.3>= 3.0.0, < 3.4.1
    Fixed in
    3.4.1, 2.25.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Impact In certain configurations, Apollo Server serves the client-side web app "GraphQL Playground" from the same web server that executes GraphQL operations. This web app has access to cookies and other credentials associated with the web server's operations. There is a cross-site scripting vulnerability in GraphQL Playground that allows for arbitrary JavaScript code execution in your web server's origin. If a user clicks a specially crafted link to your GraphQL Playground page served by Apollo Server, an attacker can steal cookies and other private browser data. Details of the underlying GraphQL Playground vulnerability are available in this graphql-playground advisory. (A similar vulnerability exists in the related graphiql project.) This advisory focuses on identifying whether Apollo Server installations are vulnerable and mitigating the vulnerability in Apollo Server; see the other advisories for details on the XSS vulnerability itself. The impact of this vulnerability is more…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-qm7x-rc44-rrqw

  2. Revision 1 · created ·

    Published from osv record GHSA-qm7x-rc44-rrqw

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-qm7x-rc44-rrqw

Advisory: Cross-site Scripting Vulnerability in GraphQL Playground (distributed by Apollo Server)
IDs: GHSA-qm7x-rc44-rrqw
Record: https://patchnext.com/advisories/ghsa-qm7x-rc44-rrqw (revision 2, source checked 26 Oct 2026, 12:15 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: apollo-server 3.4.1, 2.25.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm apollo-server: affected >= 2.0.0, < 2.25.3; >= 3.0.0, < 3.4.1; fixed in 3.4.1, 2.25.3

## Suggested inspection (read-only)
- `npm ls apollo-server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on apollo-server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-qm7x-rc44-rrqw (OSV record GHSA-qm7x-rc44-rrqw lists affected ranges: npm apollo-server >=2.0.0 =3.0.0 <3.4.1 (fixed))
- Verified: https://github.com/advisories/GHSA-qm7x-rc44-rrqw (GitHub-reviewed advisory GHSA-qm7x-rc44-rrqw lists affected ranges: npm apollo-server >=2.0.0 =3.0.0 <3.4.1)

Commands are suggestions: review each one before running it.

Loading voting…