SurrealDB has an Uncaught Exception Handling Parsing Errors on Empty Strings
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (surrealdb 2.0.4; surrealdb-core 2.0.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
crates.io surrealdb
- Affected
- >= 2.0.0, < 2.0.4
- Fixed in
- 2.0.4
crates.io surrealdb-core
- Affected
- >= 2.0.0, < 2.0.4
- Fixed in
- 2.0.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-qjrv-v6qp-x99x lists affected ranges: crates.io surrealdb >=2.0.0 =2.0.0 <2.0.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 7.1 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
The error rendering code from the parser would panic when handling failed parsing of queries where the error occurred when converting an empty string to a SurrealDB value. This would be the case when casting an empty string to a record, duration or datetime, as well as potentially when parsing an empty string to JSON or providing an empty string to the type::field and type::fields functions. Impact A client that is authorized to run queries in a SurrealDB server would be able to execute a malformed query which would fail to parse when converting an empty string and cause a panic in the error rendering code. This would crash the server, leading to denial of service. Patches - Version 2.0.4 and later are not affected by this issue. Workarounds Affected users who are unable to update may want to limit the ability of untrusted clients to run arbitrary SurrealQL queries in the affected versions of SurrealDB. To limit the impact of the denial of service, SurrealDB administrators may also…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-qjrv-v6qp-x99x
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-qjrv-v6qp-x99x Advisory: SurrealDB has an Uncaught Exception Handling Parsing Errors on Empty Strings IDs: GHSA-qjrv-v6qp-x99x Record: https://patchnext.com/advisories/ghsa-qjrv-v6qp-x99x (revision 1, source checked 26 Oct 2026, 15:38 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: surrealdb 2.0.4; surrealdb-core 2.0.4. A vendor fix does not mean a deployment is fixed. ## Affected components - crates.io surrealdb: affected >= 2.0.0, < 2.0.4; fixed in 2.0.4 - crates.io surrealdb-core: affected >= 2.0.0, < 2.0.4; fixed in 2.0.4 ## Suggested inspection (read-only) - crates.io surrealdb: check the installed version with your package manager. - crates.io surrealdb-core: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on surrealdb, surrealdb-core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-qjrv-v6qp-x99x (GitHub-reviewed advisory GHSA-qjrv-v6qp-x99x lists affected ranges: crates.io surrealdb >=2.0.0 =2.0.0 <2.0.4) Commands are suggestions: review each one before running it.
Loading voting…