Skip to content

← Actionable
Critical, CVSS 9.8

ZendFramework potential SQL Injection Vector When Using PDO_MySql

GHSA-qf36-fx9f-232x

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (zendframework/zendframework1 1.11.6, 1.10.9), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Developers using non-ASCII-compatible encodings in conjunction with the MySQL PDO driver of PHP may be vulnerable to SQL injection attacks. Developers using ASCII-compatible encodings like UTF8 or latin1 are not affected by this PHP issue, which is described in more detail here: http://bugs.php.net/bug.php?id=47802 The PHP Group included a feature in PHP 5.3.6+ that allows any character set information to be passed as part of the DSN in PDO to allow both the database as well as the C-level driver to be aware of which charset is in use which is of special importance when PDO's quoting mechanisms are utilized, which Zend Framework also relies on.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-qf36-fx9f-232x

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-qf36-fx9f-232x

Advisory: ZendFramework potential SQL Injection Vector When Using PDO_MySql
IDs: GHSA-qf36-fx9f-232x
Record: https://patchnext.com/advisories/ghsa-qf36-fx9f-232x (revision 1, source checked 26 Oct 2026, 14:25 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: zendframework/zendframework1 1.11.6, 1.10.9. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist zendframework/zendframework1: affected >= 1.10.0, < 1.10.9; >= 1.11.0, < 1.11.6; fixed in 1.11.6, 1.10.9

## Suggested inspection (read-only)
- Packagist zendframework/zendframework1: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on zendframework/zendframework1.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-qf36-fx9f-232x (GitHub-reviewed advisory GHSA-qf36-fx9f-232x lists affected ranges: Packagist zendframework/zendframework1 >=1.10.0 =1.11.0 <1.11.6)

Commands are suggestions: review each one before running it.

Loading voting…