Skip to content

← Actionable
Unrated

Pageflow vulnerable to insecure direct object reference in membership update endpoint

GHSA-qcqv-38jg-2r43

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (pageflow 15.7.1, 14.5.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • RubyGems pageflow

    Affected
    < 14.5.2>= 15.0.0, < 15.7.1
    Fixed in
    14.5.2, 15.7.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Impact Pageflow has a membership edit feature which allows users to edit the roles of user memberships associated with an account that they have the manager role to (including their own). While the Entity dropdown select field is greyed out in the UI, an attacker can use tools which allow sending arbitrary HTTP request to craft a request to the /admin/users/{userid}/memberships/{membershipid} endpoint containing an additional membership[entityid] parameter. This parameter is honored when the membership is updated, allowing an attacker to update the membership object associated with their own account (with manager role) to be associated with a different attacker-chosen account instead. Since accountids are enumerable, an attacker can compromise all accounts present on the platform. Mitigation Upgrade to version 15.7.1 or 14.5.2 of the pageflow gem. For more information If you have any questions or comments about this advisory email us at info(at)codevise.de Credits Positive Security

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-qcqv-38jg-2r43

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-qcqv-38jg-2r43

Advisory: Pageflow vulnerable to insecure direct object reference in membership update endpoint
IDs: GHSA-qcqv-38jg-2r43
Record: https://patchnext.com/advisories/ghsa-qcqv-38jg-2r43 (revision 1, source checked 26 Oct 2026, 15:43 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: pageflow 15.7.1, 14.5.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems pageflow: affected < 14.5.2; >= 15.0.0, < 15.7.1; fixed in 14.5.2, 15.7.1

## Suggested inspection (read-only)
- RubyGems pageflow: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on pageflow.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-qcqv-38jg-2r43 (GitHub-reviewed advisory GHSA-qcqv-38jg-2r43 lists affected ranges: RubyGems pageflow >=0 =15.0.0 <15.7.1)

Commands are suggestions: review each one before running it.

Loading voting…