Skip to content

← Actionable
High, CVSS 7.0amended

OpenClaw: Sandbox dangling-symlink alias handling could bypass workspace-only write boundary

GHSA-qcc4-p59m-p54m

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (openclaw 2026.2.26), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm openclaw

    Affected
    <= 2026.2.25
    Fixed in
    2026.2.26

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.0 · CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Summary A sandbox boundary-validation gap in symlink alias handling allowed certain workspace-only write paths to be treated as in-boundary even when they could resolve outside the workspace/sandbox root. Affected Packages / Versions - Package: npm openclaw - Affected versions: <= 2026.2.25 - Latest published npm version included in affected range: 2026.2.25 (checked on February 26, 2026) - Patched version (pre-set for release): 2026.2.26 Technical Details In affected versions, dangling symlink hops could be accepted during boundary checks under missing-target conditions. For workspace-only write flows (including applypatch), this could allow writes to resolve outside the configured workspace/sandbox boundary. The fix resolves symlink targets through existing ancestors and fails closed when canonical resolution escapes the configured boundary. Impact - Boundary-confined write operations could be redirected outside the configured workspace/sandbox root. - Primary impact is integrity…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-qcc4-p59m-p54m

  2. Revision 1 · created ·

    Published from osv record GHSA-qcc4-p59m-p54m

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-qcc4-p59m-p54m

Advisory: OpenClaw: Sandbox dangling-symlink alias handling could bypass workspace-only write boundary
IDs: GHSA-qcc4-p59m-p54m
Record: https://patchnext.com/advisories/ghsa-qcc4-p59m-p54m (revision 2, source checked 26 Oct 2026, 12:43 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: openclaw 2026.2.26. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm openclaw: affected <= 2026.2.25; fixed in 2026.2.26

## Suggested inspection (read-only)
- `npm ls openclaw --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on openclaw.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-qcc4-p59m-p54m (OSV record GHSA-qcc4-p59m-p54m lists affected ranges: npm openclaw >=0 <2026.2.26 (fixed))
- Verified: https://github.com/advisories/GHSA-qcc4-p59m-p54m (GitHub-reviewed advisory GHSA-qcc4-p59m-p54m lists affected ranges: npm openclaw >=0 <=2026.2.25)

Commands are suggestions: review each one before running it.

Loading voting…