Skip to content

← Actionable
High, CVSS 7.3

Graylog Allows Stored Cross-Site Scripting via Files Plugin and API Browser

GHSA-q9q2-3ppx-mwqf

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.graylog2:graylog2-server 6.2.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:N
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Impact Two minor vulnerabilities were identified in the Graylog2 enterprise server, which can be combined to carry out a stored cross-site scripting attack. An attacker with the permission FILESCREATE can exploit these vulnerabilities to upload arbitrary Javascript code to the Graylog2 server, which - upon requesting of the file by a user of the API browser - results in the execution of this Javascript code in the context of the Graylog frontend application. This enables the attacker to carry out authenticated API requests with the permissions of the logged-in user, thereby taking over the user session. Patches The generic API has been removed in 6.2.0 rendering the attack vector unreachable and additional escaping has been added. Analysis provided by Fabian Yamaguchi - Whirly Labs (Pty) Ltd

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-q9q2-3ppx-mwqf

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-q9q2-3ppx-mwqf

Advisory: Graylog Allows Stored Cross-Site Scripting via Files Plugin and API Browser
IDs: GHSA-q9q2-3ppx-mwqf
Record: https://patchnext.com/advisories/ghsa-q9q2-3ppx-mwqf (revision 1, source checked 26 Oct 2026, 16:36 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.graylog2:graylog2-server 6.2.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.graylog2:graylog2-server: affected < 6.2.0; fixed in 6.2.0

## Suggested inspection (read-only)
- Maven org.graylog2:graylog2-server: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.graylog2:graylog2-server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-q9q2-3ppx-mwqf (GitHub-reviewed advisory GHSA-q9q2-3ppx-mwqf lists affected ranges: Maven org.graylog2:graylog2-server >=0 <6.2.0)

Commands are suggestions: review each one before running it.

Loading voting…