potato-annotation has a Project-Boundary Bypass
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (potato-annotation 2.4.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI potato-annotation
- Affected
- >= 2.0.0, < 2.4.5
- Fixed in
- 2.4.5
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-q9m2-fhv9-3jcf lists affected ranges: PyPI potato-annotation >=2.0.0 <2.4.5 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-q9m2-fhv9-3jcf lists affected ranges: PyPI potato-annotation >=2.0.0 <2.4.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.1 · CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Summary validatepathsecurity uses string-prefix containment (startswith) for boundary checks. This allows paths that are outside the intended project directory but share its prefix string (e.g., /tmp/potatoprojdemoevil/... vs /tmp/potatoprojdemo) to be accepted. Details Affected source location (root cause) File: potato/serverutils/configmodule.py Snippet (lines 370–373): Snippet (lines 384–389): startswith() is string-based, so /tmp/potatoprojdemoevil/... passes when checked against /tmp/potatoprojdemo. Confirmed affected call sites File: potato/serverutils/configmodule.py 1) validatefilepaths taskdir branch (line 2113) 2) validatefilepaths datafiles branch (line 2151) 3) validatetrainingconfig training.datafile branch (line 2286) PoC Impact - Can allow unauthorized sibling-prefix file access outside intended project boundary. - Can affect read paths (datafiles, training.datafile, basecss, headerlogo) and output/path placement depending on configuration.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-q9m2-fhv9-3jcf
- Revision 1 · created ·
Published from osv record GHSA-q9m2-fhv9-3jcf
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-q9m2-fhv9-3jcf Advisory: `potato-annotation` has a Project-Boundary Bypass IDs: GHSA-q9m2-fhv9-3jcf Record: https://patchnext.com/advisories/ghsa-q9m2-fhv9-3jcf (revision 2, source checked 26 Oct 2026, 13:41 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: potato-annotation 2.4.5. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI potato-annotation: affected >= 2.0.0, < 2.4.5; fixed in 2.4.5 ## Suggested inspection (read-only) - `python -m pip show potato-annotation`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on potato-annotation. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-q9m2-fhv9-3jcf (OSV record GHSA-q9m2-fhv9-3jcf lists affected ranges: PyPI potato-annotation >=2.0.0 <2.4.5 (fixed)) - Verified: https://github.com/advisories/GHSA-q9m2-fhv9-3jcf (GitHub-reviewed advisory GHSA-q9m2-fhv9-3jcf lists affected ranges: PyPI potato-annotation >=2.0.0 <2.4.5) Commands are suggestions: review each one before running it.
Loading voting…