Skip to content

← Actionable
Medium, CVSS 6.5amended

ha-mcp: Add-on settings and policy routes are reachable without authentication at the bare root path

GHSA-q855-8rh5-jfgq

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (ha-mcp 7.10.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI ha-mcp

    Affected
    < 7.10.0
    Fixed in
    7.10.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:L
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Summary In add-on mode, the ha-mcp settings UI routes are mounted both under the MCP secret path and at the bare root of the published port (:9583), so Home Assistant ingress can serve the "Open Web UI" button. The root-mounted routes perform no authentication — no secret, no Origin check, no CSRF token — so any client that can reach :9583 without the MCP secret can invoke them. Affected configurations Home Assistant add-on installations (hostnetwork: true with port 9583 published), v7.6.0 and earlier. Docker and standalone installs are not affected — there the settings routes are mounted only under the secret path. Root-mounted routes in affected versions: tool visibility (/api/settings/tools GET/POST), feature flags (/api/settings/features GET/POST), the auto-backup suite (/api/settings/backups… incl. restore/delete, and /api/settings/backup-config), add-on restart (/api/settings/restart), and — when the opt-in Tool Security Policies feature is enabled — the approval-policy API…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-q855-8rh5-jfgq

  2. Revision 1 · created ·

    Published from osv record GHSA-q855-8rh5-jfgq

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-q855-8rh5-jfgq

Advisory: ha-mcp: Add-on settings and policy routes are reachable without authentication at the bare root path
IDs: GHSA-q855-8rh5-jfgq
Record: https://patchnext.com/advisories/ghsa-q855-8rh5-jfgq (revision 2, source checked 26 Oct 2026, 13:46 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: ha-mcp 7.10.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI ha-mcp: affected < 7.10.0; fixed in 7.10.0

## Suggested inspection (read-only)
- `python -m pip show ha-mcp`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on ha-mcp.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-q855-8rh5-jfgq (OSV record GHSA-q855-8rh5-jfgq lists affected ranges: PyPI ha-mcp >=0 <7.10.0 (fixed))
- Verified: https://github.com/advisories/GHSA-q855-8rh5-jfgq (GitHub-reviewed advisory GHSA-q855-8rh5-jfgq lists affected ranges: PyPI ha-mcp >=0 <7.10.0)

Commands are suggestions: review each one before running it.

Loading voting…