Skip to content

← Actionable
High, CVSS 8.1amended

better-auth: Device login approval does not show the requesting client or permissions

CVE-2026-109346GHSA-q84f-53jg-9ppm

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (better-auth 1.7.0-rc.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm better-auth

    Affected
    >= 1.3.8-beta.3, < 1.7.0-rc.3
    Fixed in
    1.7.0-rc.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:N
EPSS
  • CVE-2026-109346: 0.28% estimated exploitation activity in the next 30 days; percentile 20.34 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Am I affected? You may be affected if you use `better-auth` from `1.3.8-beta.3` up to, but not including, `1.7.0-rc.3`, and you enable the `deviceAuthorization()` plugin. This range includes all 1.6 releases. You are affected only if all of these are also true: - An attacker can start a device request: `validateClient` is not configured, or the attacker can use a valid public client. - Before allowing approval, your approval page does not show, from server-checked data, which client is asking and the exact permissions it requests. - Users may approve a code or complete verification link they did not start and cannot compare with a device they have. - Your application accepts the session token that the device flow returns, for example through the bearer plugin. You are not affected if you do not enable the opt-in `deviceAuthorization()` plugin.

Summary The device authorization plugin lets a user sign in on one device by approving a short code on another. In affected versions,…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from osv record GHSA-q84f-53jg-9ppm

  2. Revision 1 · created ·

    Published from ghsa record GHSA-q84f-53jg-9ppm

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-109346

Advisory: better-auth: Device login approval does not show the requesting client or permissions
IDs: CVE-2026-109346, GHSA-q84f-53jg-9ppm
Record: https://patchnext.com/advisories/ghsa-q84f-53jg-9ppm (revision 2, source checked 28 Oct 2026, 06:00 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: better-auth 1.7.0-rc.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm better-auth: affected >= 1.3.8-beta.3, < 1.7.0-rc.3; fixed in 1.7.0-rc.3

## Suggested inspection (read-only)
- `npm ls better-auth --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on better-auth.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-q84f-53jg-9ppm (GitHub-reviewed advisory GHSA-q84f-53jg-9ppm lists affected ranges: npm better-auth >=1.3.8-beta.3 <1.7.0-rc.3)
- Verified: https://osv.dev/vulnerability/GHSA-q84f-53jg-9ppm (OSV record GHSA-q84f-53jg-9ppm lists affected ranges: npm better-auth >=1.3.8-beta.3 <1.7.0-rc.3 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…