CakePHP vulnerable to Denial of Service attack through XML payloads
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (cakephp/cakephp 3.0.6, 2.6.6, 2.5.90, 2.4.99, 2.3.99, 2.2.99, 2.1.99, 2.0.99), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist cakephp/cakephp
- Affected
- >= 3.0.0, < 3.0.6>= 2.0.0, < 2.0.99>= 2.1.0, < 2.1.99>= 2.2.0, < 2.2.99>= 2.3.0, < 2.3.99>= 2.4.0, < 2.4.99>= 2.5.0, < 2.5.90>= 2.6.0, < 2.6.6
- Fixed in
- 3.0.6, 2.0.99, 2.4.99, 2.5.90, 2.2.99, 2.1.99, 2.3.99, 2.6.6
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-q79m-c546-2g63 lists affected ranges: Packagist cakephp/cakephp >=3.0.0 =2.0.0 =2.1.0 =2.2.0 =2.3.0 =2.4.0 =2.5.0 =2.6.0 <2.6.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
RequestHandlerComponent had a vulnerability that would allow well crafted requests to create a denial of service attack. RequestHandlerComponent leverages Xml::build() which allows reading local files. We recommend that all applications using RequestHandlerComponent upgrade, or disable parsing XML payloads.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-q79m-c546-2g63
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-q79m-c546-2g63 Advisory: CakePHP vulnerable to Denial of Service attack through XML payloads IDs: GHSA-q79m-c546-2g63 Record: https://patchnext.com/advisories/ghsa-q79m-c546-2g63 (revision 1, source checked 26 Oct 2026, 13:56 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: cakephp/cakephp 3.0.6, 2.6.6, 2.5.90, 2.4.99, 2.3.99, 2.2.99, 2.1.99, 2.0.99. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist cakephp/cakephp: affected >= 3.0.0, < 3.0.6; >= 2.0.0, < 2.0.99; >= 2.1.0, < 2.1.99; >= 2.2.0, < 2.2.99; >= 2.3.0, < 2.3.99; >= 2.4.0, < 2.4.99; >= 2.5.0, < 2.5.90; >= 2.6.0, < 2.6.6; fixed in 3.0.6, 2.0.99, 2.4.99, 2.5.90, 2.2.99, 2.1.99, 2.3.99, 2.6.6 ## Suggested inspection (read-only) - Packagist cakephp/cakephp: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on cakephp/cakephp. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-q79m-c546-2g63 (GitHub-reviewed advisory GHSA-q79m-c546-2g63 lists affected ranges: Packagist cakephp/cakephp >=3.0.0 =2.0.0 =2.1.0 =2.2.0 =2.3.0 =2.4.0 =2.5.0 =2.6.0 <2.6.6) Commands are suggestions: review each one before running it.
Loading voting…