Skip to content

← Actionable
Low, CVSS 2.3

kcp is missing update validation allows arbitrary LogicalCluster status patches through initializingworkspaces Virtual Workspace

GHSA-q6hv-wcjr-wp8h

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/kcp-dev/kcp 0.28.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
2.3 · CVSS:4.0/AV:N/AC:H/AT:P/PR:L/UI:N/VC:N/VI:L/VA:N/SC:N/SI:L/SA:N · score source
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Impact Because UPDATE validation is not being applied, it is possible for an actor with access to an instance of the initializingworkspaces virtual workspace to run arbitrary patches on the status field of LogicalCluster objects while the workspace is initializing. This allows to add or remove any initializers as well as changing the phase of a LogicalCluster (to "Ready" for example). As this effectively allows to skip certain initializers or the entire initialization phase, potential integrations with external systems such as billing or security could be affected. Their initializers could be skipped by a WorkspaceType that adds another initializer and grants permissions to the virtual workspace to a rogue or compromised entity. Who is impacted? Impacts other owners of WorkspaceTypes with initializers that are inherited by other WorkspaceTypes. Impacts developers using the virtual/framework package to create their own virtualworkspaces if they are using UpdateFuncs in their custom…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-q6hv-wcjr-wp8h

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-q6hv-wcjr-wp8h

Advisory: kcp is missing update validation allows arbitrary LogicalCluster status patches through initializingworkspaces Virtual Workspace
IDs: GHSA-q6hv-wcjr-wp8h
Record: https://patchnext.com/advisories/ghsa-q6hv-wcjr-wp8h (revision 1, source checked 26 Oct 2026, 15:13 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 2.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/kcp-dev/kcp 0.28.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/kcp-dev/kcp: affected <= 0.28.1; fixed in 0.28.3

## Suggested inspection (read-only)
- Go github.com/kcp-dev/kcp: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/kcp-dev/kcp.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-q6hv-wcjr-wp8h (GitHub-reviewed advisory GHSA-q6hv-wcjr-wp8h lists affected ranges: Go github.com/kcp-dev/kcp >=0 <=0.28.1)

Commands are suggestions: review each one before running it.

Loading voting…