WebauthnAuthenticator leaks sensitive HTTP headers through INFO-level logs
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (web-auth/webauthn-symfony-bundle 5.3.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist web-auth/webauthn-symfony-bundle
- Affected
- < 5.3.4
- Fixed in
- 5.3.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-q683-8468-r6h6 lists affected ranges: Packagist web-auth/webauthn-symfony-bundle >=0 <5.3.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.6 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N/E:U · score source
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Impact Webauthn\Bundle\Security\Http\Authenticator\WebauthnAuthenticator logs the full Symfony\Component\HttpFoundation\Request object inside the log context of both onAuthenticationSuccess() and onAuthenticationFailure() at INFO level: Request::toString() returns the raw HTTP message, including every request header. As soon as the configured logger normalises or stringifies the context (default behaviour for LineFormatter, JsonFormatter via NormalizerFormatter, etc.), sensitive headers such as Cookie (session identifier), Authorization and any custom auth header are written to the log stream in clear text. Applications that forward logs to centralised platforms (ELK, Splunk, Datadog and similar) are particularly exposed: log access is typically broader than application access, which can allow log readers to hijack authenticated sessions. Affected versions Every release prior to 5.3.4 is affected. Patches The fix removes the full Request object from the log context and keeps only…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-q683-8468-r6h6
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-q683-8468-r6h6 Advisory: WebauthnAuthenticator leaks sensitive HTTP headers through INFO-level logs IDs: GHSA-q683-8468-r6h6 Record: https://patchnext.com/advisories/ghsa-q683-8468-r6h6 (revision 1, source checked 26 Oct 2026, 14:49 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: web-auth/webauthn-symfony-bundle 5.3.4. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist web-auth/webauthn-symfony-bundle: affected < 5.3.4; fixed in 5.3.4 ## Suggested inspection (read-only) - Packagist web-auth/webauthn-symfony-bundle: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on web-auth/webauthn-symfony-bundle. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-q683-8468-r6h6 (GitHub-reviewed advisory GHSA-q683-8468-r6h6 lists affected ranges: Packagist web-auth/webauthn-symfony-bundle >=0 <5.3.4) Commands are suggestions: review each one before running it.
Loading voting…