Bitcoinrb Vulnerable to Command injection via RPC
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (bitcoinrb 1.12.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems bitcoinrb
- Affected
- < 1.12.0
- Fixed in
- 1.12.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-q66h-m87m-j2q6 lists affected ranges: RubyGems bitcoinrb >=0 <1.12.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 2.0 · CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:P · score source
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Summary: Remote Code Execution Unsafe handling of request parameters in the RPC HTTP server results in command injection Details In lib/bitcoin/rpc/httpserver.rb line 30-39, the JSON body of a POST request is parsed into command and args variables. These values are then passed to send, which is used to call an arbitrary class method. However, there is no validation that the provided command value is one of the expected RPC methods. This means that an attacker could supply a command value such as system, and then pass arbitrary system commands into the args parameter and achieve remote code execution. PoC 1. Start the RPC server 2. Send a request to the RPC server as so: 3. Check the /tmp folder on the machine where the RPC server is being run. If a folder /pwned now exists, the vulnerability is confirmed. Impact This vulnerability would impact anyone running the RPC server. The impact is higher for those who are running it publicly exposed to the internet. Remediation Mitigating…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-q66h-m87m-j2q6
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-q66h-m87m-j2q6 Advisory: Bitcoinrb Vulnerable to Command injection via RPC IDs: GHSA-q66h-m87m-j2q6 Record: https://patchnext.com/advisories/ghsa-q66h-m87m-j2q6 (revision 1, source checked 26 Oct 2026, 15:51 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 2.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: bitcoinrb 1.12.0. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems bitcoinrb: affected < 1.12.0; fixed in 1.12.0 ## Suggested inspection (read-only) - RubyGems bitcoinrb: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on bitcoinrb. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-q66h-m87m-j2q6 (GitHub-reviewed advisory GHSA-q66h-m87m-j2q6 lists affected ranges: RubyGems bitcoinrb >=0 <1.12.0) Commands are suggestions: review each one before running it.
Loading voting…