Denial of Service in express-fileupload
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (express-fileupload 1.1.6-alpha.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 1.1.6-alpha.6<= 1.1.3-alpha.2<= 1.1.2-alpha.1<= 1.1.1-alpha.3<= 1.0.0-alpha.1
- Fixed in
- 1.1.6-alpha.6
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-q3w9-g74q-vp5f lists affected ranges: npm express-fileupload >=0 <1.1.6-alpha.6 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-q3w9-g74q-vp5f lists affected ranges: npm express-fileupload >=0 =0 =0 =0 =0 <=1.0.0-alpha.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Versions of express-fileupload prior to 1.1.6-alpha.6 are vulnerable to Denial of Service. The package causes server responses to be delayed (up to 30s in internal testing) if the request contains a large filename of . characters. Recommendation Upgrade to version 1.1.6-alpha.6 or later.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-q3w9-g74q-vp5f
- Revision 1 · created ·
Published from osv record GHSA-q3w9-g74q-vp5f
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-q3w9-g74q-vp5f Advisory: Denial of Service in express-fileupload IDs: GHSA-q3w9-g74q-vp5f Record: https://patchnext.com/advisories/ghsa-q3w9-g74q-vp5f (revision 2, source checked 26 Oct 2026, 12:15 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: express-fileupload 1.1.6-alpha.6. A vendor fix does not mean a deployment is fixed. ## Affected components - npm express-fileupload: affected < 1.1.6-alpha.6; <= 1.1.3-alpha.2; <= 1.1.2-alpha.1; <= 1.1.1-alpha.3; <= 1.0.0-alpha.1; fixed in 1.1.6-alpha.6 ## Suggested inspection (read-only) - `npm ls express-fileupload --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on express-fileupload. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-q3w9-g74q-vp5f (OSV record GHSA-q3w9-g74q-vp5f lists affected ranges: npm express-fileupload >=0 <1.1.6-alpha.6 (fixed)) - Verified: https://github.com/advisories/GHSA-q3w9-g74q-vp5f (GitHub-reviewed advisory GHSA-q3w9-g74q-vp5f lists affected ranges: npm express-fileupload >=0 =0 =0 =0 =0 <=1.0.0-alpha.1) Commands are suggestions: review each one before running it.
Loading voting…