Shopware Remote Code Execution Vulnerability
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (shopware/shopware 5.2.15, 1.0.8), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist shopware/shopware
- Affected
- >= 4.0.0, < 5.2.15< 1.0.8
- Fixed in
- 5.2.15, 1.0.8
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-q3g4-2vw9-xv27 lists affected ranges: Packagist shopware/shopware >=4.0.0 =0 <1.0.8
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Under certain circumstances, it’s possible to execute an unauthorized foreign code in Shopware. This is a critical security vulnerability that could affect the entire system. All Shopware versions including Shopware 5.2.14 are affected.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-q3g4-2vw9-xv27
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-q3g4-2vw9-xv27 Advisory: Shopware Remote Code Execution Vulnerability IDs: GHSA-q3g4-2vw9-xv27 Record: https://patchnext.com/advisories/ghsa-q3g4-2vw9-xv27 (revision 1, source checked 26 Oct 2026, 14:24 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: shopware/shopware 5.2.15, 1.0.8. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist shopware/shopware: affected >= 4.0.0, < 5.2.15; < 1.0.8; fixed in 5.2.15, 1.0.8 ## Suggested inspection (read-only) - Packagist shopware/shopware: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on shopware/shopware. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-q3g4-2vw9-xv27 (GitHub-reviewed advisory GHSA-q3g4-2vw9-xv27 lists affected ranges: Packagist shopware/shopware >=4.0.0 =0 <1.0.8) Commands are suggestions: review each one before running it.
Loading voting…