Bypass of CMS Safe Mode Security Feature
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (wintercms/winter 1.1.9, 1.0.475), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist wintercms/winter
- Affected
- < 1.0.475>= 1.1.0, < 1.1.9
- Fixed in
- 1.1.9, 1.0.475
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-q37h-jhf3-85cj lists affected ranges: Packagist wintercms/winter >=0 =1.1.0 <1.1.9
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Impact Authenticated users with permissions to create or modify theme template objects through the backend "CMS" editor can exploit this vulnerability to bypass the cms.enableSafeMode security feature if enabled (disables modification of PHP code through the web interface when enabled). This is only an issue for Winter CMS instances that rely on the Safe Mode security feature to prevent privileged users from modifying the PHP code of CMS theme template objects through the web interface. CVSS v3.1 Vector: AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H/E:P/RL:O/RC:C Patches Issue has been fixed in v1.0.475, v1.1.9, & v1.2. Workarounds Apply https://github.com/wintercms/storm/commit/03eb5ce3f2a271670574802b914f7bcaf07663c1 manually if unable to upgrade to v1.0.475, v1.1.9, or v1.2.0. References See https://github.com/octobercms/october/security/advisories/GHSA-79jw-2f46-wv22/. Credit to David Miller for reporting the issue. For more information If you have any questions or comments about this…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-q37h-jhf3-85cj
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-q37h-jhf3-85cj Advisory: Bypass of CMS Safe Mode Security Feature IDs: GHSA-q37h-jhf3-85cj Record: https://patchnext.com/advisories/ghsa-q37h-jhf3-85cj (revision 1, source checked 26 Oct 2026, 13:56 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: wintercms/winter 1.1.9, 1.0.475. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist wintercms/winter: affected < 1.0.475; >= 1.1.0, < 1.1.9; fixed in 1.1.9, 1.0.475 ## Suggested inspection (read-only) - Packagist wintercms/winter: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on wintercms/winter. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-q37h-jhf3-85cj (GitHub-reviewed advisory GHSA-q37h-jhf3-85cj lists affected ranges: Packagist wintercms/winter >=0 =1.1.0 <1.1.9) Commands are suggestions: review each one before running it.
Loading voting…