Apiman Vert.x Gateway has Transitive Hazelcast connection caching issue
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (io.apiman:apiman-distro-vertx 3.0.0.Final; io.apiman:apiman-gateway-platforms-vertx 3.0.0.Final), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven io.apiman:apiman-distro-vertx
- Affected
- < 3.0.0.Final
- Fixed in
- 3.0.0.Final
Maven io.apiman:apiman-gateway-platforms-vertx
- Affected
- < 3.0.0.Final
- Fixed in
- 3.0.0.Final
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-q2fj-6h62-59m2 lists affected ranges: Maven io.apiman:apiman-gateway-platforms-vertx >=0 =0 <3.0.0.Final
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.1 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Impact If you are using the Apiman Vert.x Gateway prior to Apiman 3.0.0.Final, a connection caching issue in Hazelcast could allow an unauthenticated, remote attacker to access and manipulate data in the cluster with another authenticated connection's identity. Hazelcast is a transitive dependency of the Apiman Vert.x Gateway. The precise risk is difficult to quantify at this juncture as plugins deployed by users may make use of Hazelcast in a different manner to the main Apiman codebase. If any of your custom Apiman plugins specify Hazelcast dependencies, you should also bump these versions. Hint: an easy way to track Apiman dependency versions is to use apiman-parent. If you use the Apiman Tomcat or WildFly Gateway this does not affect you. Patches Upgrade to Apiman 3.0.0.Final or later. If you are using an older version of Apiman and need to remain on that version, contact to your Apiman support provider for advice/long-term support. Workarounds None (other than doing your own…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-q2fj-6h62-59m2
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-q2fj-6h62-59m2 Advisory: Apiman Vert.x Gateway has Transitive Hazelcast connection caching issue IDs: GHSA-q2fj-6h62-59m2 Record: https://patchnext.com/advisories/ghsa-q2fj-6h62-59m2 (revision 1, source checked 26 Oct 2026, 15:52 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: io.apiman:apiman-distro-vertx 3.0.0.Final; io.apiman:apiman-gateway-platforms-vertx 3.0.0.Final. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven io.apiman:apiman-distro-vertx: affected < 3.0.0.Final; fixed in 3.0.0.Final - Maven io.apiman:apiman-gateway-platforms-vertx: affected < 3.0.0.Final; fixed in 3.0.0.Final ## Suggested inspection (read-only) - Maven io.apiman:apiman-distro-vertx: check the installed version with your package manager. - Maven io.apiman:apiman-gateway-platforms-vertx: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on io.apiman:apiman-distro-vertx, io.apiman:apiman-gateway-platforms-vertx. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-q2fj-6h62-59m2 (GitHub-reviewed advisory GHSA-q2fj-6h62-59m2 lists affected ranges: Maven io.apiman:apiman-gateway-platforms-vertx >=0 =0 <3.0.0.Final) Commands are suggestions: review each one before running it.
Loading voting…