Skip to content

← Actionable
High, CVSS 8.7

libcrux-sha3: Incorrect output from SHAKE squeeze functions

GHSA-q29p-9pfr-j652

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (libcrux-sha3 0.0.8), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N · score source
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

The incremental squeeze functions in the portable SHAKE XOF API, when attempting to squeeze more than RATE (168 for SHAKE128, 136 for SHAKE256) bytes, performed an additional permutation of the state before producing the first output block, thus discarding the first block of RATE bytes of valid XOF output. Impact This bug impacts users that rely on this XOF API to squeeze more than RATE bytes. It does not impact the use of libcrux-sha3 in libcrux-ml-kem or libcrux-ml-dsa. Mitigation Starting from version 0.0.8 the squeeze functions correctly output all blocks including the first block.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-q29p-9pfr-j652

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-q29p-9pfr-j652

Advisory: libcrux-sha3: Incorrect output from SHAKE squeeze functions
IDs: GHSA-q29p-9pfr-j652
Record: https://patchnext.com/advisories/ghsa-q29p-9pfr-j652 (revision 1, source checked 26 Oct 2026, 15:42 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: libcrux-sha3 0.0.8. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io libcrux-sha3: affected < 0.0.8; fixed in 0.0.8

## Suggested inspection (read-only)
- crates.io libcrux-sha3: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on libcrux-sha3.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-q29p-9pfr-j652 (GitHub-reviewed advisory GHSA-q29p-9pfr-j652 lists affected ranges: crates.io libcrux-sha3 >=0 <0.0.8)

Commands are suggestions: review each one before running it.

Loading voting…