Tesla Fleet Telemetry allows spoofing telemetry for arbitrary vehicles via compromised vehicle credentials
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/teslamotors/fleet-telemetry 0.9.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/teslamotors/fleet-telemetry
- Affected
- <= 0.8.0
- Fixed in
- 0.9.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-prxj-3gcv-cqrh lists affected ranges: Go github.com/teslamotors/fleet-telemetry >=0 <=0.8.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.9 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Summary A vulnerability in vehicle authentication allows threat actor with valid client credentials (i.e., a private key and certificate from a rooted infotainment system) to impersonate arbitrary VINs when authenticating to the telemetry server. Impact The attacker would be able to submit falsified telemetry records for arbitrary VINs.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-prxj-3gcv-cqrh
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-prxj-3gcv-cqrh Advisory: Tesla Fleet Telemetry allows spoofing telemetry for arbitrary vehicles via compromised vehicle credentials IDs: GHSA-prxj-3gcv-cqrh Record: https://patchnext.com/advisories/ghsa-prxj-3gcv-cqrh (revision 1, source checked 26 Oct 2026, 15:19 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/teslamotors/fleet-telemetry 0.9.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/teslamotors/fleet-telemetry: affected <= 0.8.0; fixed in 0.9.0 ## Suggested inspection (read-only) - Go github.com/teslamotors/fleet-telemetry: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/teslamotors/fleet-telemetry. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-prxj-3gcv-cqrh (GitHub-reviewed advisory GHSA-prxj-3gcv-cqrh lists affected ranges: Go github.com/teslamotors/fleet-telemetry >=0 <=0.8.0) Commands are suggestions: review each one before running it.
Loading voting…