Skip to content

← Actionable
Unrated

Potential privilege escalation on Kubernetes >= v1.19 when the Argo Sever is run with --auth-mode=client

GHSA-prqf-xr2j-xf65

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/argoproj/argo-workflows/v3 3.1.6, 3.0.9), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Impact This is pro-active fix. No know exploits exist. Impacted: You're running Kubernetes = v1.19 You're running Argo Server It is configured to with --auth-mode=client Is not configured with --auth-mode=server You are not running Argo Server in Kubernetes pod. E.g. on bare metal or other VM. You're using client key to authenticate on the server. The server has more permissions that the connecting client's account. The client's authentication will be ignored and the server's authentication will be used. This will result in privilege escalation to that of the the server's account. Patches https://github.com/argoproj/argo-workflows/pull/6506 Workarounds None.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-prqf-xr2j-xf65

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-prqf-xr2j-xf65

Advisory: Potential privilege escalation on Kubernetes >= v1.19 when the Argo Sever is run with `--auth-mode=client`
IDs: GHSA-prqf-xr2j-xf65
Record: https://patchnext.com/advisories/ghsa-prqf-xr2j-xf65 (revision 1, source checked 26 Oct 2026, 14:54 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/argoproj/argo-workflows/v3 3.1.6, 3.0.9. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/argoproj/argo-workflows/v3: affected >= 3.0.0, < 3.0.9; >= 3.1.0, < 3.1.6; fixed in 3.1.6, 3.0.9

## Suggested inspection (read-only)
- Go github.com/argoproj/argo-workflows/v3: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/argoproj/argo-workflows/v3.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-prqf-xr2j-xf65 (GitHub-reviewed advisory GHSA-prqf-xr2j-xf65 lists affected ranges: Go github.com/argoproj/argo-workflows/v3 >=3.0.0 =3.1.0 <3.1.6)

Commands are suggestions: review each one before running it.

Loading voting…