Trigger.dev Self-Hosted Deployment: Default Secrets allow Unauthenticated Infrastructure Compromise
CVE-2026-114087GHSA-pqxw-g93w-hj9x
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (trigger.dev 4.5.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm trigger.dev
- Affected
- <= 4.5.5
- Fixed in
- 4.5.6
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-pqxw-g93w-hj9x lists affected ranges: npm trigger.dev >=0 <=4.5.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-pqxw-g93w-hj9x lists affected ranges: npm trigger.dev >=0 <4.5.6 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.1 · CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N/E:P · score source
- EPSS
- CVE-2026-114087: 0.51% estimated exploitation activity in the next 30 days; percentile 43.75 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Self-hosted trigger.dev v4 instances deployed using the provided Docker Compose configuration with default secrets from hosting/docker/.env.example are vulnerable to a multi-stage unauthenticated attack chain leading to complete infrastructure compromise. Vulnerability Details The hosting/docker/.env.example file contains hardcoded cryptographic secrets: The MAGICLINKSECRET is used by remix-auth-email-link@2.0.2 to create authentication tokens via CryptoJS AES encryption. An attacker who knows this secret can forge valid magic links that authenticate as any email address without email delivery. The validateSessionMagicLink option defaults to false in the library (never overridden by trigger.dev), so no session-side validation occurs. User accounts are auto-created when WHITELISTEDEMAILS is not set (the default for self-hosted). Steps to Reproduce Setup Step 1: Forge magic link token Step 2: Authenticate via forged magic link Step 3: Verify database access from runner network…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 4 · amended ·
Amended from ghsa record GHSA-pqxw-g93w-hj9x
- Revision 3 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 2 · amended ·
Amended from osv record GHSA-pqxw-g93w-hj9x
- Revision 1 · created ·
Published from ghsa record GHSA-pqxw-g93w-hj9x
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-114087 Advisory: Trigger.dev Self-Hosted Deployment: Default Secrets allow Unauthenticated Infrastructure Compromise IDs: CVE-2026-114087, GHSA-pqxw-g93w-hj9x Record: https://patchnext.com/advisories/ghsa-pqxw-g93w-hj9x (revision 4, source checked 26 Oct 2026, 13:06 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: trigger.dev 4.5.6. A vendor fix does not mean a deployment is fixed. ## Affected components - npm trigger.dev: affected <= 4.5.5; fixed in 4.5.6 ## Suggested inspection (read-only) - `npm ls trigger.dev --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on trigger.dev. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-pqxw-g93w-hj9x (GitHub-reviewed advisory GHSA-pqxw-g93w-hj9x lists affected ranges: npm trigger.dev >=0 <=4.5.5) - Verified: https://osv.dev/vulnerability/GHSA-pqxw-g93w-hj9x (OSV record GHSA-pqxw-g93w-hj9x lists affected ranges: npm trigger.dev >=0 <4.5.6 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…