simd-json-derive vulnerable to MaybeUninit misuse
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (simd-json-derive 0.12.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
crates.io simd-json-derive
- Affected
- < 0.12.0
- Fixed in
- 0.12.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-pqpw-89w5-82v5 lists affected ranges: crates.io simd-json-derive >=0 <0.12.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.6 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:U · score source
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
An invalid use of MaybeUninit::uninit().assumeinit() in simd-json-derive's derive macro can cause undefined behavior. The original code used MaybeUninit to avoid initialisation of the struct and then set the fields using ptr::write. The undefined behavior triggered by this misuse of MaybeUninit can lead to invlaid memory access and panics in binaries compiled in release mode (aka simd-json-derive prior to version 0.12 has UB and optimizes into some nonsense) The version 0.12.0 removes this section of code, avoiding the use of MaybeUninit alltogether.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-pqpw-89w5-82v5
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-pqpw-89w5-82v5 Advisory: `simd-json-derive` vulnerable to `MaybeUninit` misuse IDs: GHSA-pqpw-89w5-82v5 Record: https://patchnext.com/advisories/ghsa-pqpw-89w5-82v5 (revision 1, source checked 26 Oct 2026, 15:38 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: simd-json-derive 0.12.0. A vendor fix does not mean a deployment is fixed. ## Affected components - crates.io simd-json-derive: affected < 0.12.0; fixed in 0.12.0 ## Suggested inspection (read-only) - crates.io simd-json-derive: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on simd-json-derive. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-pqpw-89w5-82v5 (GitHub-reviewed advisory GHSA-pqpw-89w5-82v5 lists affected ranges: crates.io simd-json-derive >=0 <0.12.0) Commands are suggestions: review each one before running it.
Loading voting…