PocketMine-MP vulnerable to server crash with certain invalid JSON payloads in LoginPacket due to vulnerable dependency
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (pocketmine/pocketmine-mp 4.21.1, 4.20.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist pocketmine/pocketmine-mp
- Affected
- < 4.20.5>= 4.21.0, < 4.21.1
- Fixed in
- 4.20.5, 4.21.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-pqp3-8rrw-g8vm lists affected ranges: Packagist pocketmine/pocketmine-mp >=0 =4.21.0 <4.21.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Impact An attacker could crash PocketMine-MP by sending malformed JSON in LoginPacket. This happened due to a bug in netresearch/jsonmapper. The library wasn't doing proper checks when mapping JSON arrays and objects onto scalar model properties such as strings. Patches The problem was fixed in a fork of JsonMapper in dktapps/JsonMapper@a31902a31f5b6fdb832f57c0e3a3f16a3b41c012. PocketMine-MP releases 4.20.5 and 4.21.1 have been released with the fix. Workarounds - Users of PocketMine-MP source installations may manually install the patched version of JsonMapper by backporting commit pmmp/PocketMine-MP@09668a37d66c6023685a948b7550c918620e98f2. - A plugin may also be able to workaround this issue by using DataPacketReceiveEvent to attempt detection of suspicious payloads. An ErrorException will be thrown in the crash case, which can be caught by plugins. References cweiske/jsonmapper#210
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-pqp3-8rrw-g8vm
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-pqp3-8rrw-g8vm Advisory: PocketMine-MP vulnerable to server crash with certain invalid JSON payloads in `LoginPacket` due to vulnerable dependency IDs: GHSA-pqp3-8rrw-g8vm Record: https://patchnext.com/advisories/ghsa-pqp3-8rrw-g8vm (revision 1, source checked 26 Oct 2026, 14:24 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: pocketmine/pocketmine-mp 4.21.1, 4.20.5. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist pocketmine/pocketmine-mp: affected < 4.20.5; >= 4.21.0, < 4.21.1; fixed in 4.20.5, 4.21.1 ## Suggested inspection (read-only) - Packagist pocketmine/pocketmine-mp: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on pocketmine/pocketmine-mp. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-pqp3-8rrw-g8vm (GitHub-reviewed advisory GHSA-pqp3-8rrw-g8vm lists affected ranges: Packagist pocketmine/pocketmine-mp >=0 =4.21.0 <4.21.1) Commands are suggestions: review each one before running it.
Loading voting…