Ez Platform and Legacy are prone to an insecure interpretation of PHP/PHAR uploads
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (ezsystems/ezpublish-legacy 2018.9.1.3, 2018.6.1.4, 2017.12.4.3, 5.4.12.3, 5.3.12.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist ezsystems/ezpublish-legacy
- Affected
- >= 2018.9.0, < 2018.9.1.3>= 2018.6.0, < 2018.6.1.4>= 2011.0.0, < 2017.12.4.3>= 5.4.0, < 5.4.12.3>= 5.3.0, < 5.3.12.6
- Fixed in
- 5.3.12.6, 5.4.12.3, 2018.9.1.3, 2017.12.4.3, 2018.6.1.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-pqjm-xcp8-wgmm lists affected ranges: Packagist ezsystems/ezpublish-legacy >=2018.9.0 =2018.6.0 =2011.0.0 =5.4.0 =5.3.0 <5.3.12.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
The eZ Platform and Legacy are affected by an issue related to how uploaded PHP and PHAR files are handled, and consists of two parts: 1. Web server configuration, and 2. Disabling the PHAR stream wrapper. 1. WEB SERVER CONFIGURATION The sample web server configuration in our documentation can in some cases allow the execution of uploaded PHP/PHAR code. This can be abused to allow priviledge escalation and breach of content access controls, among other things. Please ensure that your web server will not execute files in directories were files may be uploaded, such as web/var/ and ezpublishlegacy/var/ As an example, here is how you can make Apache return HTTP 403 Forbidden for a number of executable file types in your eZ Platform var directory. Please adapt it to your needs. It is then possible to enable logging of HTTP 403 in a separate log file if you wish, you could do this to see if someone is trying to abuse the server. Here is the same configuration, but for the Nginx web…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-pqjm-xcp8-wgmm
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-pqjm-xcp8-wgmm Advisory: Ez Platform and Legacy are prone to an insecure interpretation of PHP/PHAR uploads IDs: GHSA-pqjm-xcp8-wgmm Record: https://patchnext.com/advisories/ghsa-pqjm-xcp8-wgmm (revision 1, source checked 26 Oct 2026, 14:24 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: ezsystems/ezpublish-legacy 2018.9.1.3, 2018.6.1.4, 2017.12.4.3, 5.4.12.3, 5.3.12.6. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist ezsystems/ezpublish-legacy: affected >= 2018.9.0, < 2018.9.1.3; >= 2018.6.0, < 2018.6.1.4; >= 2011.0.0, < 2017.12.4.3; >= 5.4.0, < 5.4.12.3; >= 5.3.0, < 5.3.12.6; fixed in 5.3.12.6, 5.4.12.3, 2018.9.1.3, 2017.12.4.3, 2018.6.1.4 ## Suggested inspection (read-only) - Packagist ezsystems/ezpublish-legacy: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on ezsystems/ezpublish-legacy. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-pqjm-xcp8-wgmm (GitHub-reviewed advisory GHSA-pqjm-xcp8-wgmm lists affected ranges: Packagist ezsystems/ezpublish-legacy >=2018.9.0 =2018.6.0 =2011.0.0 =5.4.0 =5.3.0 <5.3.12.6) Commands are suggestions: review each one before running it.
Loading voting…