Skip to content

← Actionable
Medium, CVSS 5.3amended

smol-toml has a Denial of Service via malicious TOML document using deeply nested inline tables

GHSA-pqhp-25j4-6hq9

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (smol-toml 1.3.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Summary An attacker can send a maliciously crafted TOML to cause the parser to crash because of a stack overflow caused by a deeply nested inline structure. A similar problem occurs when attempting to stringify deeply nested objects. The library does not limit the maximum exploration depth while parsing or producing TOML documents, nor does it offer a way to do so. Proof of concept Impact Applications which parse arbitrary TOML documents may suffer availability issues if they receive malicious input. If uncaught, the crash may cause the application itself to crash. The impact is deemed minor, as the function is already likely to throw errors on invalid input and therefore to properly handle errors. Due to the design of most JavaScript runtimes, the uncontrolled recursion does not lead to excessive memory usage and the execution is quickly aborted. As a reminder, it is strongly advised when working with untrusted user input to expect errors to occur and to appropriately catch them.…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-pqhp-25j4-6hq9

  2. Revision 1 · created ·

    Published from osv record GHSA-pqhp-25j4-6hq9

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-pqhp-25j4-6hq9

Advisory: smol-toml has a Denial of Service via malicious TOML document using deeply nested inline tables
IDs: GHSA-pqhp-25j4-6hq9
Record: https://patchnext.com/advisories/ghsa-pqhp-25j4-6hq9 (revision 2, source checked 26 Oct 2026, 12:31 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: smol-toml 1.3.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm smol-toml: affected <= 1.3.0; fixed in 1.3.1

## Suggested inspection (read-only)
- `npm ls smol-toml --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on smol-toml.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-pqhp-25j4-6hq9 (OSV record GHSA-pqhp-25j4-6hq9 lists affected ranges: npm smol-toml >=0 <1.3.1 (fixed))
- Verified: https://github.com/advisories/GHSA-pqhp-25j4-6hq9 (GitHub-reviewed advisory GHSA-pqhp-25j4-6hq9 lists affected ranges: npm smol-toml >=0 <=1.3.0)

Commands are suggestions: review each one before running it.

Loading voting…