Skip to content

← Actionable
Medium, CVSS 4.3

@dynatrace-oss/dynatrace-mcp-server has a DQL injection via parameters not documented as DQL

GHSA-pqh8-p93p-2rx7

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@dynatrace-oss/dynatrace-mcp-server 2.1.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:N
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Summary A DQL injection vulnerability in several read tools lets a caller bypass the tools' documented field-scope, time-window, and display caps by injecting DQL pipeline stages through parameters typed as identifiers. Details Several tools interpolate caller-supplied parameters directly into DQL query strings without quoting or escaping. The affected parameters are documented in their Zod schemas as identifiers or constrained shorthand (such as "24h" timeframe values or Kubernetes UIDs) - not as DQL expressions. The interpolation lets a caller break out of string literals, append arbitrary DQL pipeline stages, and use // line comments (documented in the Dynatrace DQL language reference) to discard the rest of the intended query. The marginal-privilege ceiling is low because the operator's token also exposes executedql with full DQL access. What the injection grants is the ability to bypass the affected tools' contract: the readOnlyHint: true annotation that MCP clients may treat as…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-pqh8-p93p-2rx7

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-pqh8-p93p-2rx7

Advisory: @dynatrace-oss/dynatrace-mcp-server has a DQL injection via parameters not documented as DQL
IDs: GHSA-pqh8-p93p-2rx7
Record: https://patchnext.com/advisories/ghsa-pqh8-p93p-2rx7 (revision 1, source checked 26 Oct 2026, 13:00 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @dynatrace-oss/dynatrace-mcp-server 2.1.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @dynatrace-oss/dynatrace-mcp-server: affected < 2.1.1; fixed in 2.1.1

## Suggested inspection (read-only)
- `npm ls @dynatrace-oss/dynatrace-mcp-server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @dynatrace-oss/dynatrace-mcp-server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-pqh8-p93p-2rx7 (GitHub-reviewed advisory GHSA-pqh8-p93p-2rx7 lists affected ranges: npm @dynatrace-oss/dynatrace-mcp-server >=0 <2.1.1)

Commands are suggestions: review each one before running it.

Loading voting…