Skip to content

← Actionable
Unratedamended

Taipy 3.1.1 affected by CVEs on flask-core and pymongo

GHSA-pp84-v3mw-gg4w

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (taipy 4.0.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI taipy

    Affected
    <= 3.1.1
    Fixed in
    4.0.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Summary Indirect CVEs affect Taipy 3.1.1 Details Taipy 3.1.1 is affected by two existing CVEs: CVE-2024-1681 affects flask-core <4.0.1 and taipy 3.1.1 needs <=4.0.0 CVE-2024-5629 affects pymongo <4.6.3 and taipy 3.1.1 needs <=4.6.1 Please see References for further details. Patch please upgrade to the following versions: Fixed on patch versions: =3.1.2 and on major releases: =4.0.0 Impact pre-commit breaks when using dependency Taipy 3.1.1

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-pp84-v3mw-gg4w

  2. Revision 1 · created ·

    Published from osv record GHSA-pp84-v3mw-gg4w

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-pp84-v3mw-gg4w

Advisory: Taipy 3.1.1 affected by CVEs on flask-core and pymongo
IDs: GHSA-pp84-v3mw-gg4w
Record: https://patchnext.com/advisories/ghsa-pp84-v3mw-gg4w (revision 2, source checked 26 Oct 2026, 13:21 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: taipy 4.0.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI taipy: affected <= 3.1.1; fixed in 4.0.0

## Suggested inspection (read-only)
- `python -m pip show taipy`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on taipy.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-pp84-v3mw-gg4w (OSV record GHSA-pp84-v3mw-gg4w lists affected ranges: PyPI taipy >=0 <4.0.0 (fixed))
- Verified: https://github.com/advisories/GHSA-pp84-v3mw-gg4w (GitHub-reviewed advisory GHSA-pp84-v3mw-gg4w lists affected ranges: PyPI taipy >=0 <=3.1.1)

Commands are suggestions: review each one before running it.

Loading voting…