Skip to content

← Actionable
Unrated

FOSUserBundle Entropy is lost in the TokenGenerator

GHSA-pjx8-984p-7p3x

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (friendsofsymfony/user-bundle 1.3.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Description Because of the usage of baseconvert which looses precision for large inputs, the entropy of tokens generated by FOSUserBundle for the email confirmation and password resetting is lost. This makes these tokens much less random than they are expected to be, and so not cryptographically safe. Resolution The token generation logic used in the 2.0.x branch based on base64 encoding has been backported. This changes the range of characters used in the token. Any route placeholder expected to match a token generated by FOSUserBundle must be updated to allow dashes, which are not allowed by \w in regexes. A \w+ requirement should so become [\w\-]+.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-pjx8-984p-7p3x

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-pjx8-984p-7p3x

Advisory: FOSUserBundle Entropy is lost in the TokenGenerator
IDs: GHSA-pjx8-984p-7p3x
Record: https://patchnext.com/advisories/ghsa-pjx8-984p-7p3x (revision 1, source checked 26 Oct 2026, 14:24 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: friendsofsymfony/user-bundle 1.3.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist friendsofsymfony/user-bundle: affected >= 1.0.0, < 1.3.5; fixed in 1.3.5

## Suggested inspection (read-only)
- Packagist friendsofsymfony/user-bundle: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on friendsofsymfony/user-bundle.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-pjx8-984p-7p3x (GitHub-reviewed advisory GHSA-pjx8-984p-7p3x lists affected ranges: Packagist friendsofsymfony/user-bundle >=1.0.0 <1.3.5)

Commands are suggestions: review each one before running it.

Loading voting…