motionEye Partial Authentication Bypass: Unauthenticated Admin Credential Theft via Path Traversal
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (motioneye 0.44.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI motioneye
- Affected
- < 0.44.0
- Fixed in
- 0.44.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-phv5-334h-mxcw lists affected ranges: PyPI motioneye >=0 <0.44.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-phv5-334h-mxcw lists affected ranges: PyPI motioneye >=0 <0.44.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 10.0 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H · score source
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Partial Authentication Bypass: Unauthenticated Admin Credential Theft via Path Traversal Summary Myself and others have reported several RCE vulnerabilities to this project. However, due to the nature of the app, these are largely not of all that much value, as there is built-in functionality to run commands upon certain actions — i.e. RCE is by design. With that in mind, I endeavored to find some sort of auth bypass, and was slightly successful. When the admin password is set but the normal (surveillance) user password is left empty (the default), an unauthenticated attacker can exploit a path traversal vulnerability to read the motionEye configuration file from disk. This file contains the admin password as a SHA-1 hash, and that hash is accepted directly as a signing key for admin API requests — no cracking required. The result is full admin access from zero credentials. This is a realistic scenario: many installations set an admin password to protect the settings UI but leave the…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 4 · amended ·
Amended from ghsa record GHSA-phv5-334h-mxcw
- Revision 3 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 2 · amended ·
Amended from osv record GHSA-phv5-334h-mxcw
- Revision 1 · created ·
Published from ghsa record GHSA-phv5-334h-mxcw
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-phv5-334h-mxcw Advisory: motionEye Partial Authentication Bypass: Unauthenticated Admin Credential Theft via Path Traversal IDs: GHSA-phv5-334h-mxcw Record: https://patchnext.com/advisories/ghsa-phv5-334h-mxcw (revision 4, source checked 26 Oct 2026, 13:46 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 10.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: motioneye 0.44.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI motioneye: affected < 0.44.0; fixed in 0.44.0 ## Suggested inspection (read-only) - `python -m pip show motioneye`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on motioneye. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-phv5-334h-mxcw (GitHub-reviewed advisory GHSA-phv5-334h-mxcw lists affected ranges: PyPI motioneye >=0 <0.44.0) - Verified: https://osv.dev/vulnerability/GHSA-phv5-334h-mxcw (OSV record GHSA-phv5-334h-mxcw lists affected ranges: PyPI motioneye >=0 <0.44.0 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…