Sensitive Data Exposure in pem
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (pem 1.13.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm pem
- Affected
- < 1.13.2
- Fixed in
- 1.13.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-pgcr-7wm4-mcv6 lists affected ranges: npm pem >=0 <1.13.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-pgcr-7wm4-mcv6 lists affected ranges: npm pem >=0 <1.13.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Versions of pem before 1.13.2 expose sensitive data when the readPkcs12 is used. The readPkcs12 function reads the certificate and key data from a pkcs12 file using the encryption password. As part of this process it creates a globally readable file with a filename of 20 random 0-f characters in the temporary directory containing the password which is then read by OpenSSL. The file containing the password is never cleaned up after it is used giving access to the pkcs12 password to any other users with access to read files from the system. Recommendation Update to version 1.13.2 or later.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-pgcr-7wm4-mcv6
- Revision 1 · created ·
Published from osv record GHSA-pgcr-7wm4-mcv6
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-pgcr-7wm4-mcv6 Advisory: Sensitive Data Exposure in pem IDs: GHSA-pgcr-7wm4-mcv6 Record: https://patchnext.com/advisories/ghsa-pgcr-7wm4-mcv6 (revision 2, source checked 26 Oct 2026, 12:06 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: pem 1.13.2. A vendor fix does not mean a deployment is fixed. ## Affected components - npm pem: affected < 1.13.2; fixed in 1.13.2 ## Suggested inspection (read-only) - `npm ls pem --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on pem. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-pgcr-7wm4-mcv6 (OSV record GHSA-pgcr-7wm4-mcv6 lists affected ranges: npm pem >=0 <1.13.2 (fixed)) - Verified: https://github.com/advisories/GHSA-pgcr-7wm4-mcv6 (GitHub-reviewed advisory GHSA-pgcr-7wm4-mcv6 lists affected ranges: npm pem >=0 <1.13.2) Commands are suggestions: review each one before running it.
Loading voting…