Skip to content

← Actionable
Low, CVSS 2.3amended

PocketMine-MP has potential memory/network vulnerability from repeated ResourcePackClientResponsePacket packets

CVE-2026-86198GHSA-pg53-p7qp-65cv

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (pocketmine/pocketmine-mp 5.44.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
2.3 · CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:L/VA:L/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-86198: 0.38% estimated exploitation activity in the next 30 days; percentile 32.26 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary During the resource pack stage of logging in, after the server sends `ResourcePackStackPacket`, a malicious client can send a batch of multiple `ResourcePackClientResponsePacket` packets with status `ResourcePackClientResponsePacket::STATUS_COMPLETED` causing the server to repeatedly execute pre-spawn progression.

Impact Multiple `Player` objects can be created for just a single session, increasing memory usage and amplifying outbound network traffic from duplication of large pre-spawn packets such as `AvailableCommandsPacket` and `CreativeContentPacket`.

Workarounds Plugins can use their own `PacketHandler` classes that reject/ignore any extra `ResourcePackClientResponsePacket` packets.

Patches This issue was patched in https://github.com/pmmp/PocketMine-MP/commit/7a27894146a04964ab628ed9033140fdbf887ff3 and released in 5.44.2.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from osv record GHSA-pg53-p7qp-65cv

  2. Revision 1 · created ·

    Published from ghsa record GHSA-pg53-p7qp-65cv

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-86198

Advisory: PocketMine-MP has potential memory/network vulnerability from repeated ResourcePackClientResponsePacket packets
IDs: CVE-2026-86198, GHSA-pg53-p7qp-65cv
Record: https://patchnext.com/advisories/ghsa-pg53-p7qp-65cv (revision 2, source checked 30 Oct 2026, 07:05 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 2.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: pocketmine/pocketmine-mp 5.44.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist pocketmine/pocketmine-mp: affected < 5.44.2; fixed in 5.44.2

## Suggested inspection (read-only)
- Packagist pocketmine/pocketmine-mp: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on pocketmine/pocketmine-mp.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-pg53-p7qp-65cv (GitHub-reviewed advisory GHSA-pg53-p7qp-65cv lists affected ranges: Packagist pocketmine/pocketmine-mp >=0 <5.44.2)
- Verified: https://osv.dev/vulnerability/GHSA-pg53-p7qp-65cv (OSV record GHSA-pg53-p7qp-65cv lists affected ranges: Packagist pocketmine/pocketmine-mp >=0 <5.44.2 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…