Skip to content

← Actionable
High, CVSS 8.8

toodee is vulnerable to Heap Buffer Overflow through its DrainCol Destructor

GHSA-pfp7-vxgr-83pw

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (toodee 0.6.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • crates.io toodee

    Affected
    >= 0.2.0, < 0.6.0
    Fixed in
    0.6.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.8 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:H/SC:L/SI:L/SA:L · score source
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

An off-by-one error in the DrainCol::drop destructor could cause an unsafe memory copy operation to exceed the bounds of the associated vector. The error was related to the size of the data being copied in one of the ptr::copy invocations inside the destructor. When removing the first column from a TooDee object, the DrainCol return object could cause a heap buffer overflow vulnerability when it is dropped. The issue was fixed in commit e6e16d5 by reducing the copied size by one.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-pfp7-vxgr-83pw

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-pfp7-vxgr-83pw

Advisory: toodee is vulnerable to Heap Buffer Overflow through its DrainCol Destructor
IDs: GHSA-pfp7-vxgr-83pw
Record: https://patchnext.com/advisories/ghsa-pfp7-vxgr-83pw (revision 1, source checked 26 Oct 2026, 15:39 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: toodee 0.6.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io toodee: affected >= 0.2.0, < 0.6.0; fixed in 0.6.0

## Suggested inspection (read-only)
- crates.io toodee: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on toodee.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-pfp7-vxgr-83pw (GitHub-reviewed advisory GHSA-pfp7-vxgr-83pw lists affected ranges: crates.io toodee >=0.2.0 <0.6.0)

Commands are suggestions: review each one before running it.

Loading voting…