Skip to content

← Actionable
High, CVSS 8.1

Data races in v9

GHSA-pfjq-935c-4895

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (v9 0.1.43), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • crates.io v9

    Affected
    < 0.1.43
    Fixed in
    0.1.43

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.1 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Affected versions of this crate unconditionally implement Sync for SyncRef<T. This definition allows data races if &T is accessible through &SyncRef. SyncRef<T derives Clone and Debug, and the default implementations of those traits access &T by invoking T::clone() & T::fmt(). It is possible to create data races & undefined behavior by concurrently invoking SyncRef<T::clone() or SyncRef<T::fmt() from multiple threads with T: !Sync.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-pfjq-935c-4895

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-pfjq-935c-4895

Advisory: Data races in v9
IDs: GHSA-pfjq-935c-4895
Record: https://patchnext.com/advisories/ghsa-pfjq-935c-4895 (revision 1, source checked 26 Oct 2026, 15:37 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: v9 0.1.43. A vendor fix does not mean a deployment is fixed.

## Affected components
- crates.io v9: affected < 0.1.43; fixed in 0.1.43

## Suggested inspection (read-only)
- crates.io v9: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on v9.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-pfjq-935c-4895 (GitHub-reviewed advisory GHSA-pfjq-935c-4895 lists affected ranges: crates.io v9 >=0 <0.1.43)

Commands are suggestions: review each one before running it.

Loading voting…