Graphify Fortran extractor: incomplete cpp #include hardening allows arbitrary host-file read/exfiltration when indexing an untrusted repo
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (graphifyy 0.9.70), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI graphifyy
- Affected
- >= 0.7.2, < 0.9.70
- Fixed in
- 0.9.70
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-pcc4-rvhr-2pr8 lists affected ranges: PyPI graphifyy >=0.7.2 <0.9.70
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-pcc4-rvhr-2pr8 lists affected ranges: PyPI graphifyy >=0.7.2 <0.9.70 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.8 · CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Summary The Fortran extractor's C-preprocessor step (graphify/extractors/fortran.py, cpppreprocess) applies an incomplete #include hardening. The -nostdinc -I /dev/null flags it relies on (comment "Security (F-007)") do not stop a capital-F Fortran source file from including absolute paths (#include "/etc/passwd") or from path-traversing out of the corpus (#include "../../../../home/victim/.ssh/idrsa"). cpp always searches the directory of the file being preprocessed for quoted includes and always honours absolute include paths, regardless of -nostdinc/-I. As a result, indexing an untrusted repository that contains a .F/.F90/.F95/.F03/.F08 file reads arbitrary local files off the host and inlines their contents into the knowledge graph, which is then shipped to the LLM/agent and written to the on-disk, shareable output (graph.json, GRAPHREPORT.md, the Obsidian wiki, HTML/SVG exports). This is the exact "corpus-side file-exfiltration vector" the F-007 comment says it is defending…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 4 · amended ·
Amended from ghsa record GHSA-pcc4-rvhr-2pr8
- Revision 3 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 2 · amended ·
Amended from osv record GHSA-pcc4-rvhr-2pr8
- Revision 1 · created ·
Published from ghsa record GHSA-pcc4-rvhr-2pr8
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-pcc4-rvhr-2pr8 Advisory: Graphify Fortran extractor: incomplete cpp #include hardening allows arbitrary host-file read/exfiltration when indexing an untrusted repo IDs: GHSA-pcc4-rvhr-2pr8 Record: https://patchnext.com/advisories/ghsa-pcc4-rvhr-2pr8 (revision 4, source checked 26 Oct 2026, 13:55 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: graphifyy 0.9.70. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI graphifyy: affected >= 0.7.2, < 0.9.70; fixed in 0.9.70 ## Suggested inspection (read-only) - `python -m pip show graphifyy`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on graphifyy. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-pcc4-rvhr-2pr8 (GitHub-reviewed advisory GHSA-pcc4-rvhr-2pr8 lists affected ranges: PyPI graphifyy >=0.7.2 <0.9.70) - Verified: https://osv.dev/vulnerability/GHSA-pcc4-rvhr-2pr8 (OSV record GHSA-pcc4-rvhr-2pr8 lists affected ranges: PyPI graphifyy >=0.7.2 <0.9.70 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…