Machine-In-The-Middle in https-proxy-agent
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (https-proxy-agent 2.2.3), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 2.2.3
- Fixed in
- 2.2.3
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-pc5p-h8pf-mvwp lists affected ranges: npm https-proxy-agent >=0 <2.2.3 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-pc5p-h8pf-mvwp lists affected ranges: npm https-proxy-agent >=0 <2.2.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.1 · CVSS:3.1/AV:A/AC:H/PR:N/UI:N/S:C/C:H/I:N/A:N
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Versions of https-proxy-agent prior to 2.2.3 are vulnerable to Machine-In-The-Middle. The package fails to enforce TLS on the socket if the proxy server responds the to the request with a HTTP status different than 200. This allows an attacker with access to the proxy server to intercept unencrypted communications, which may include sensitive information such as credentials. Recommendation Upgrade to version 3.0.0 or 2.2.3.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-pc5p-h8pf-mvwp
- Revision 1 · created ·
Published from osv record GHSA-pc5p-h8pf-mvwp
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-pc5p-h8pf-mvwp Advisory: Machine-In-The-Middle in https-proxy-agent IDs: GHSA-pc5p-h8pf-mvwp Record: https://patchnext.com/advisories/ghsa-pc5p-h8pf-mvwp (revision 2, source checked 26 Oct 2026, 12:27 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: https-proxy-agent 2.2.3. A vendor fix does not mean a deployment is fixed. ## Affected components - npm https-proxy-agent: affected < 2.2.3; fixed in 2.2.3 ## Suggested inspection (read-only) - `npm ls https-proxy-agent --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on https-proxy-agent. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-pc5p-h8pf-mvwp (OSV record GHSA-pc5p-h8pf-mvwp lists affected ranges: npm https-proxy-agent >=0 <2.2.3 (fixed)) - Verified: https://github.com/advisories/GHSA-pc5p-h8pf-mvwp (GitHub-reviewed advisory GHSA-pc5p-h8pf-mvwp lists affected ranges: npm https-proxy-agent >=0 <2.2.3) Commands are suggestions: review each one before running it.
Loading voting…