Skip to content

← Actionable
Low, CVSS 3.7

@dynatrace-oss/dynatrace-mcp-server's create_dynatrace_notebook missing the human-approval gate

GHSA-pc2w-4mq8-32qw

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@dynatrace-oss/dynatrace-mcp-server 1.8.7), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
3.7 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Summary A missing human-approval gate on the createdynatracenotebook tool allows a caller to create persistent tenant-visible documents containing arbitrary content (including embedded DQL that other users execute when opening the notebook) without operator consent. Details dynatrace-mcp-server registers six write tools: sendslackmessage, sendemail, sendevent, createworkflowfornotification, makeworkflowpublic, and createdynatracenotebook. Five of these call requestHumanApproval() before executing the side-effect, which elicits the operator's explicit consent through the MCP elicitation protocol. The CHANGELOG explicitly states these approval gates were added "to ensure user consent and prevent unintended actions." createdynatracenotebook does not call requestHumanApproval(). The tool was introduced in a separate release from the approval-gate retrofit and was left ungated. As a result, a caller can create persistent, tenant-visible Dynatrace notebooks containing arbitrary content…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-pc2w-4mq8-32qw

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-pc2w-4mq8-32qw

Advisory: @dynatrace-oss/dynatrace-mcp-server's create_dynatrace_notebook missing the human-approval gate
IDs: GHSA-pc2w-4mq8-32qw
Record: https://patchnext.com/advisories/ghsa-pc2w-4mq8-32qw (revision 1, source checked 26 Oct 2026, 13:00 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 3.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @dynatrace-oss/dynatrace-mcp-server 1.8.7. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @dynatrace-oss/dynatrace-mcp-server: affected < 1.8.7; fixed in 1.8.7

## Suggested inspection (read-only)
- `npm ls @dynatrace-oss/dynatrace-mcp-server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @dynatrace-oss/dynatrace-mcp-server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-pc2w-4mq8-32qw (GitHub-reviewed advisory GHSA-pc2w-4mq8-32qw lists affected ranges: npm @dynatrace-oss/dynatrace-mcp-server >=0 <1.8.7)

Commands are suggestions: review each one before running it.

Loading voting…