Skip to content

← Actionable
Unrated

eZ Publish Legacy Passwordless login for LDAP users

GHSA-p9mp-vq4v-v5m5

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (ezsystems/ezpublish-legacy 2018.9.1.1, 2018.6.1.2, 2017.12.4.1, 5.4.12.1, 5.3.12.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist ezsystems/ezpublish-legacy

    Affected
    >= 2018.9.0, < 2018.9.1.1>= 2018.6.0, < 2018.6.1.2>= 2011.0.0, < 2017.12.4.1>= 5.4.0, < 5.4.12.1>= 5.3.0, < 5.3.12.4
    Fixed in
    2017.12.4.1, 2018.6.1.2, 5.3.12.4, 5.4.12.1, 2018.9.1.1

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-p9mp-vq4v-v5m5 lists affected ranges: Packagist ezsystems/ezpublish-legacy >=2018.9.0 =2018.6.0 =2011.0.0 =5.4.0 =5.3.0 <5.3.12.4

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

This security advisory fixes a vulnerability in eZ Publish Legacy, and we recommend that you install it as soon as possible if you are using Legacy. Installations that are using the legacy LDAP login handler or the TextFile login handler in combination with the standard legacy login handler, may in rare cases be vulnerable to a failure of the standard login handler to verify passwords correctly, allowing unauthorised access. If your installation has never used the LDAP or TextFile login handlers, or never used legacy login at all, then it is not affected. Still, we recommend installing the update, to be on the safe side. To install, use Composer to update to one of the "Resolving versions" mentioned above, or apply this patch manually: https://github.com/ezsystems/ezpublish-legacy/commit/13f03a2be6c0ee4d0caaafaef05904ea9b0c4d9d

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-p9mp-vq4v-v5m5

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-p9mp-vq4v-v5m5

Advisory: eZ Publish Legacy Passwordless login for LDAP users
IDs: GHSA-p9mp-vq4v-v5m5
Record: https://patchnext.com/advisories/ghsa-p9mp-vq4v-v5m5 (revision 1, source checked 26 Oct 2026, 14:24 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: ezsystems/ezpublish-legacy 2018.9.1.1, 2018.6.1.2, 2017.12.4.1, 5.4.12.1, 5.3.12.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist ezsystems/ezpublish-legacy: affected >= 2018.9.0, < 2018.9.1.1; >= 2018.6.0, < 2018.6.1.2; >= 2011.0.0, < 2017.12.4.1; >= 5.4.0, < 5.4.12.1; >= 5.3.0, < 5.3.12.4; fixed in 2017.12.4.1, 2018.6.1.2, 5.3.12.4, 5.4.12.1, 2018.9.1.1

## Suggested inspection (read-only)
- Packagist ezsystems/ezpublish-legacy: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on ezsystems/ezpublish-legacy.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-p9mp-vq4v-v5m5 (GitHub-reviewed advisory GHSA-p9mp-vq4v-v5m5 lists affected ranges: Packagist ezsystems/ezpublish-legacy >=2018.9.0 =2018.6.0 =2011.0.0 =5.4.0 =5.3.0 <5.3.12.4)

Commands are suggestions: review each one before running it.

Loading voting…