@dynatrace-oss/dynatrace-mcp-server has Unauthenticated HTTP MCP Tool Invocation
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@dynatrace-oss/dynatrace-mcp-server 2.0.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @dynatrace-oss/dynatrace-mcp-server
- Affected
- <= 1.8.7
- Fixed in
- 2.0.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-p7w7-4929-vpj5 lists affected ranges: npm @dynatrace-oss/dynatrace-mcp-server >=0 <=1.8.7
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:L/A:L
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Summary @dynatrace-oss/dynatrace-mcp-server v1.8.5 exposes an HTTP transport mode (--http flag) that performs no authentication, session validation, or origin/host verification before dispatching MCP tool calls. Any network-reachable attacker can send a raw JSON-RPC tools/call request without an Authorization header and have it executed directly under the victim server's Dynatrace credentials. Confirmed high-impact tools reachable without authentication include executedql (reads arbitrary Grail data, including logs, security events, and user sessions) and createdynatracenotebook (writes notebooks to the tenant). Details When the server is started with the --http flag, an HTTP server is created at src/index.ts:1621. For every inbound request the handler creates a new StreamableHTTPServerTransport instance: No bearer-token check, session token, Host allowlist, or Origin allowlist is configured on either the transport or in the surrounding request handler. The raw body is parsed and…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-p7w7-4929-vpj5
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-p7w7-4929-vpj5 Advisory: `@dynatrace-oss/dynatrace-mcp-server` has Unauthenticated HTTP MCP Tool Invocation IDs: GHSA-p7w7-4929-vpj5 Record: https://patchnext.com/advisories/ghsa-p7w7-4929-vpj5 (revision 1, source checked 26 Oct 2026, 13:00 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @dynatrace-oss/dynatrace-mcp-server 2.0.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @dynatrace-oss/dynatrace-mcp-server: affected <= 1.8.7; fixed in 2.0.0 ## Suggested inspection (read-only) - `npm ls @dynatrace-oss/dynatrace-mcp-server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @dynatrace-oss/dynatrace-mcp-server. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-p7w7-4929-vpj5 (GitHub-reviewed advisory GHSA-p7w7-4929-vpj5 lists affected ranges: npm @dynatrace-oss/dynatrace-mcp-server >=0 <=1.8.7) Commands are suggestions: review each one before running it.
Loading voting…