dbt uses a SQLparse version with a high vulnerability
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (dbt-core 1.7.13, 1.6.13), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI dbt-core
- Affected
- >= 1.6.0, < 1.6.13>= 1.7.0, < 1.7.13
- Fixed in
- 1.7.13, 1.6.13
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-p72q-h37j-3hq7 lists affected ranges: PyPI dbt-core >=1.6.0 =1.7.0 <1.7.13 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-p72q-h37j-3hq7 lists affected ranges: PyPI dbt-core >=1.6.0 =1.7.0 <1.7.13
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Summary Using a version of sqlparse that has a security vulnerability and no way to update in current version of dbt core. Snyk recommends using sqlparse==0.5 but this causes a conflict with dbt. Snyk states the issues is a recursion error: SNYK-PYTHON-SQLPARSE-6615674. Details Dependency conflict error message: Resolution was to pin sqlparse =0.5.0, <0.6.0 in dbt-core, patched in 1.6.13 and 1.7.13. PoC From Snyk: Impact Snyk classifies it as high 7.5/10. Patches The bug has been fixed in dbt-core v1.6.13 and dbt-core v1.7.13. Mitigations Bump dbt-core 1.6 and 1.7 dependencies to 1.6.13 and 1.7.13 respectively
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-p72q-h37j-3hq7
- Revision 1 · created ·
Published from osv record GHSA-p72q-h37j-3hq7
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-p72q-h37j-3hq7 Advisory: dbt uses a SQLparse version with a high vulnerability IDs: GHSA-p72q-h37j-3hq7 Record: https://patchnext.com/advisories/ghsa-p72q-h37j-3hq7 (revision 2, source checked 26 Oct 2026, 13:13 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: dbt-core 1.7.13, 1.6.13. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI dbt-core: affected >= 1.6.0, < 1.6.13; >= 1.7.0, < 1.7.13; fixed in 1.7.13, 1.6.13 ## Suggested inspection (read-only) - `python -m pip show dbt-core`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on dbt-core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-p72q-h37j-3hq7 (OSV record GHSA-p72q-h37j-3hq7 lists affected ranges: PyPI dbt-core >=1.6.0 =1.7.0 <1.7.13 (fixed)) - Verified: https://github.com/advisories/GHSA-p72q-h37j-3hq7 (GitHub-reviewed advisory GHSA-p72q-h37j-3hq7 lists affected ranges: PyPI dbt-core >=1.6.0 =1.7.0 <1.7.13) Commands are suggestions: review each one before running it.
Loading voting…