SSH/SCP option injection allowing local RCE in @aiondadotcom/mcp-ssh
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@aiondadotcom/mcp-ssh 1.3.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 1.3.5
- Fixed in
- 1.3.5
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-p4h8-56qp-hpgv lists affected ranges: npm @aiondadotcom/mcp-ssh >=0 <1.3.5 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-p4h8-56qp-hpgv lists affected ranges: npm @aiondadotcom/mcp-ssh >=0 <1.3.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Impact A crafted hostAlias argument such as -oProxyCommand=... was passed to ssh/scp without an argument terminator. SSH interprets arguments starting with - as options regardless of position, so the option-injection caused SSH to execute the attacker-supplied ProxyCommand locally on the machine running the MCP server — before any network connection. This bypassed the documented protection of
@password: annotations and exposed local SSH keys, browser cookies, other MCP server credentials, and anything else readable by the server process. A second local-RCE vector existed on Windows: spawn(..., { shell: true }) was used so that ssh.exe/scp.exe could be found via PATH. With shell: true, every argument is re-parsed by cmd.exe, so shell metacharacters (&, |, ^, , ", ;, …) in hostAlias, command, localPath or remotePath would have been interpreted by cmd.exe and could have triggered arbitrary local command execution on Windows. The MCP server runs locally over STDIO, but the LLM driving…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-p4h8-56qp-hpgv
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-p4h8-56qp-hpgv
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-p4h8-56qp-hpgv Advisory: SSH/SCP option injection allowing local RCE in @aiondadotcom/mcp-ssh IDs: GHSA-p4h8-56qp-hpgv Record: https://patchnext.com/advisories/ghsa-p4h8-56qp-hpgv (revision 3, source checked 26 Oct 2026, 12:48 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @aiondadotcom/mcp-ssh 1.3.5. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @aiondadotcom/mcp-ssh: affected < 1.3.5; fixed in 1.3.5 ## Suggested inspection (read-only) - `npm ls @aiondadotcom/mcp-ssh --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @aiondadotcom/mcp-ssh. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-p4h8-56qp-hpgv (OSV record GHSA-p4h8-56qp-hpgv lists affected ranges: npm @aiondadotcom/mcp-ssh >=0 <1.3.5 (fixed)) - Verified: https://github.com/advisories/GHSA-p4h8-56qp-hpgv (GitHub-reviewed advisory GHSA-p4h8-56qp-hpgv lists affected ranges: npm @aiondadotcom/mcp-ssh >=0 <1.3.5) Commands are suggestions: review each one before running it.
Loading voting…