Sveltejs devalue's devalue.parse and devalue.unflatten emit objects with __proto__ own properties
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (devalue 5.6.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm devalue
- Affected
- >= 4.0.0, < 5.6.4
- Fixed in
- 5.6.4
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-mwv9-gp5h-frr4 lists affected ranges: npm devalue >=4.0.0 <5.6.4 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-mwv9-gp5h-frr4 lists affected ranges: npm devalue >=4.0.0 <5.6.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 2.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:U · score source
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
In some circumstances, devalue.parse and devalue.unflatten could emit objects with proto own properties. This in and of itself is not a security vulnerability (and is possible with, for example, JSON.parse as well), but it can result in prototype injection if downstream code handles it incorrectly:
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-mwv9-gp5h-frr4
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-mwv9-gp5h-frr4
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-mwv9-gp5h-frr4 Advisory: Sveltejs devalue's `devalue.parse` and `devalue.unflatten` emit objects with `__proto__` own properties IDs: GHSA-mwv9-gp5h-frr4 Record: https://patchnext.com/advisories/ghsa-mwv9-gp5h-frr4 (revision 3, source checked 26 Oct 2026, 12:56 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 2.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: devalue 5.6.4. A vendor fix does not mean a deployment is fixed. ## Affected components - npm devalue: affected >= 4.0.0, < 5.6.4; fixed in 5.6.4 ## Suggested inspection (read-only) - `npm ls devalue --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on devalue. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-mwv9-gp5h-frr4 (OSV record GHSA-mwv9-gp5h-frr4 lists affected ranges: npm devalue >=4.0.0 <5.6.4 (fixed)) - Verified: https://github.com/advisories/GHSA-mwv9-gp5h-frr4 (GitHub-reviewed advisory GHSA-mwv9-gp5h-frr4 lists affected ranges: npm devalue >=4.0.0 <5.6.4) Commands are suggestions: review each one before running it.
Loading voting…