Zod denial of service vulnerability during email validation
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (express-zod-api 10.0.0-beta1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm express-zod-api
- Affected
- < 10.0.0-beta1
- Fixed in
- 10.0.0-beta1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-mvrp-3cvx-c325 lists affected ranges: npm express-zod-api >=0 <10.0.0-beta1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-mvrp-3cvx-c325 lists affected ranges: npm express-zod-api >=0 <10.0.0-beta1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Impact API servers running express-zod-api having: - version of express-zod-api below 10.0.0-beta1, - and using the following (or similar) validation schema in its implementation: z.string().email(), are vulnerable to a DoS attack due to: - Inefficient Regular Expression Complexity in zod versions up to 3.22.2, - depending on zod. Patches The patched version of zod fixing the vulnerability is 3.22.3. However, it's highly recommended to upgrade express-zod-api to at least version 10.0.0, which does not depend on zod strictly and directly, but requires its installation as a peer dependency instead, enabling you to install the patched zod version yourself. Workarounds When it's not possible to upgrade your dependencies, consider the following replacement in your implementation: This regular expression is taken from the suggested patch of zod. References - Original issue: https://github.com/colinhacks/zod/issues/2609 - The patch: https://github.com/colinhacks/zod/pull/2824 - Entry in…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-mvrp-3cvx-c325
- Revision 1 · created ·
Published from osv record GHSA-mvrp-3cvx-c325
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-mvrp-3cvx-c325 Advisory: Zod denial of service vulnerability during email validation IDs: GHSA-mvrp-3cvx-c325 Record: https://patchnext.com/advisories/ghsa-mvrp-3cvx-c325 (revision 2, source checked 26 Oct 2026, 12:26 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: express-zod-api 10.0.0-beta1. A vendor fix does not mean a deployment is fixed. ## Affected components - npm express-zod-api: affected < 10.0.0-beta1; fixed in 10.0.0-beta1 ## Suggested inspection (read-only) - `npm ls express-zod-api --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on express-zod-api. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-mvrp-3cvx-c325 (OSV record GHSA-mvrp-3cvx-c325 lists affected ranges: npm express-zod-api >=0 <10.0.0-beta1 (fixed)) - Verified: https://github.com/advisories/GHSA-mvrp-3cvx-c325 (GitHub-reviewed advisory GHSA-mvrp-3cvx-c325 lists affected ranges: npm express-zod-api >=0 <10.0.0-beta1) Commands are suggestions: review each one before running it.
Loading voting…