Skip to content

← Actionable
High, CVSS 7.5

AlchemyCMS: Unauthenticated nested page API leaks restricted & unpublished content

GHSA-mqq5-j7w8-2hgh

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (alchemy_cms 8.2.6, 8.1.14, 8.0.15, 7.4.15), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • RubyGems alchemy_cms

    Affected
    >= 8.2.0, <= 8.2.5>= 8.1.0, <= 8.1.13>= 8.0.0.a, <= 8.0.14<= 7.4.14
    Fixed in
    7.4.15, 8.0.15, 8.1.14, 8.2.6

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Unauthenticated nested page API leaks restricted & unpublished content - Location: app/controllers/alchemy/api/pagescontroller.rb:28 (Api::PagesController#nested) - Affected version: Alchemy CMS 8.3.0.dev (Rails 8.1.3) Description The unauthenticated GET /api/pages/nested endpoint returns the full page tree to any anonymous caller, including restricted (member-only) pages and unpublished/draft pages that should be hidden. Appending ?elements=true additionally dumps the element/ingredient content of restricted pages, fully bypassing the access control the sibling show and index actions enforce. Root cause Api::PagesController#nested calls no authorize! and applies no published/restricted scoping, unlike show (authorize! :show) and index (accessibleby(currentability, :index)). PageTreePreloader loads page.selfanddescendants unfiltered, and PageTreeSerializer emits every page's metadata (and, with elements, publicversion.elements) with no ability check. Evidence An unauthenticated GET…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-mqq5-j7w8-2hgh

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-mqq5-j7w8-2hgh

Advisory: AlchemyCMS: Unauthenticated nested page API leaks restricted & unpublished content
IDs: GHSA-mqq5-j7w8-2hgh
Record: https://patchnext.com/advisories/ghsa-mqq5-j7w8-2hgh (revision 1, source checked 26 Oct 2026, 15:52 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: alchemy_cms 8.2.6, 8.1.14, 8.0.15, 7.4.15. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems alchemy_cms: affected >= 8.2.0, <= 8.2.5; >= 8.1.0, <= 8.1.13; >= 8.0.0.a, <= 8.0.14; <= 7.4.14; fixed in 7.4.15, 8.0.15, 8.1.14, 8.2.6

## Suggested inspection (read-only)
- RubyGems alchemy_cms: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on alchemy_cms.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-mqq5-j7w8-2hgh (GitHub-reviewed advisory GHSA-mqq5-j7w8-2hgh lists affected ranges: RubyGems alchemy_cms >=8.2.0 =8.1.0 =8.0.0.a =0 <=7.4.14)

Commands are suggestions: review each one before running it.

Loading voting…