package pkcs12: Authentication bypass in Decode functions
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (software.sslmate.com/src/go-pkcs12 0.7.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go software.sslmate.com/src/go-pkcs12
- Affected
- >= 0.6.0, < 0.7.2
- Fixed in
- 0.7.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-mpwr-8vm7-h73f lists affected ranges: Go software.sslmate.com/src/go-pkcs12 >=0.6.0 <0.7.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-mpwr-8vm7-h73f lists affected ranges: Go software.sslmate.com/src/go-pkcs12 >=0.6.0 <0.7.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.3 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- No dated EPSS signal available.
Source description
As published by the source; long descriptions are shortened.
Decode, DecodeChain, DecodeTrustStore, and ToPEM can incorrectly accept PKCS#12 files which were encoded with the wrong password, due to a failure to reject excessively-short PBMAC1 keys. Users who decode PKCS#12 files from untrusted sources and rely on the password for authentication can be tricked into accepting malicious PKCS#12 files. Users who only decode PKCS#12 files from trusted sources are not affected. Thanks to Pavol Žáčik (Red Hat) and Alex Gaynor (Anthropic) for finding and reporting the same issue in OpenSSL (CVE-2026-34181).
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-mpwr-8vm7-h73f
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-mpwr-8vm7-h73f
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: GHSA-mpwr-8vm7-h73f Advisory: package pkcs12: Authentication bypass in Decode functions IDs: GHSA-mpwr-8vm7-h73f Record: https://patchnext.com/advisories/ghsa-mpwr-8vm7-h73f (revision 3, source checked 26 Oct 2026, 15:28 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: software.sslmate.com/src/go-pkcs12 0.7.2. A vendor fix does not mean a deployment is fixed. ## Affected components - Go software.sslmate.com/src/go-pkcs12: affected >= 0.6.0, < 0.7.2; fixed in 0.7.2 ## Suggested inspection (read-only) - Go software.sslmate.com/src/go-pkcs12: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on software.sslmate.com/src/go-pkcs12. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-mpwr-8vm7-h73f (OSV record GHSA-mpwr-8vm7-h73f lists affected ranges: Go software.sslmate.com/src/go-pkcs12 >=0.6.0 <0.7.2 (fixed)) - Verified: https://github.com/advisories/GHSA-mpwr-8vm7-h73f (GitHub-reviewed advisory GHSA-mpwr-8vm7-h73f lists affected ranges: Go software.sslmate.com/src/go-pkcs12 >=0.6.0 <0.7.2) Commands are suggestions: review each one before running it.
Loading voting…