Skip to content

← Actionable
Medium, CVSS 4.3amended

Winter: My Account preview exposes another backend user's profile by record ID

GHSA-mpmw-f6h6-3g26

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (winter/wn-backend-module 1.2.14), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Impact Backend\Controllers\MyAccount, introduced in v1.2.13, declares an empty $requiredPermissions array so that any authenticated backend user can manage their own account. It implements the FormController behavior, which exposes three routable actions — create, update and preview — that each take a record id from the URL. index() passes the authenticated user's own id to the behavior, but the inherited actions were left routable and formFindModelObject() was not scoped, so a caller-supplied id resolved against an unscoped Backend\Models\User query: preview disclosed the target user's first name, last name, login, email address and avatar; update was equally routable and additionally disclosed role, group membership, superuser flag and throttle state. Password controls render a mask, so no credential material was exposed. Backend user ids are sequential and trivially enumerated, and as these are GET actions no CSRF token is involved. The behavior's AJAX handlers (createonSave,…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-mpmw-f6h6-3g26

  2. Revision 1 · created ·

    Published from osv record GHSA-mpmw-f6h6-3g26

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-mpmw-f6h6-3g26

Advisory: Winter: My Account preview exposes another backend user's profile by record ID
IDs: GHSA-mpmw-f6h6-3g26
Record: https://patchnext.com/advisories/ghsa-mpmw-f6h6-3g26 (revision 2, source checked 26 Oct 2026, 14:50 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: winter/wn-backend-module 1.2.14. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist winter/wn-backend-module: affected >= 1.2.13, <= 1.2.13; fixed in 1.2.14

## Suggested inspection (read-only)
- Packagist winter/wn-backend-module: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on winter/wn-backend-module.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-mpmw-f6h6-3g26 (OSV record GHSA-mpmw-f6h6-3g26 lists affected ranges: Packagist winter/wn-backend-module >=1.2.13 <1.2.14 (fixed))
- Verified: https://github.com/advisories/GHSA-mpmw-f6h6-3g26 (GitHub-reviewed advisory GHSA-mpmw-f6h6-3g26 lists affected ranges: Packagist winter/wn-backend-module >=1.2.13 <=1.2.13)

Commands are suggestions: review each one before running it.

Loading voting…