Skip to content

← Actionable
Medium, CVSS 6.5amended

Livewire: Authorization bypass in #[Authorize] via reordered parameter keys and #[Json] execution order

GHSA-mhf7-xp6r-6qrc

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (livewire/livewire 4.4.8), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.5 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Impact Three issues allowed actions protected by the #[Authorize] attribute to run against records the current user is not authorized for: 1. Out-of-order parameter keys on actions. #[Authorize] resolved a model parameter by its array key, while the action itself received parameters positionally. A request sending params as an object with reordered integer keys (e.g. {"1": 2, "0": 1}) could pass authorization with a record the user owns while the action received a different record. With #[Authorize('delete', 'comment')] on deleteComment(Comment $comment), a user could delete another user's comment. 2. The same issue on event listeners. Methods using both #[On] and #[Authorize] with a model parameter were affected in the same way through the dispatch call. 3. #[Json] methods ran before authorization. When a method had both #[Json] and #[Authorize], the method body executed before the authorization check. The response was still a 403, but any side effects (such as database writes) had…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-mhf7-xp6r-6qrc

  2. Revision 2 · amended ·

    Amended from ghsa record GHSA-mhf7-xp6r-6qrc

  3. Revision 1 · created ·

    Published from osv record GHSA-mhf7-xp6r-6qrc

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-mhf7-xp6r-6qrc

Advisory: Livewire: Authorization bypass in #[Authorize] via reordered parameter keys and #[Json] execution order
IDs: GHSA-mhf7-xp6r-6qrc
Record: https://patchnext.com/advisories/ghsa-mhf7-xp6r-6qrc (revision 3, source checked 26 Oct 2026, 14:53 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: livewire/livewire 4.4.8. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist livewire/livewire: affected >= 4.3.0, < 4.4.8; fixed in 4.4.8

## Suggested inspection (read-only)
- Packagist livewire/livewire: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on livewire/livewire.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-mhf7-xp6r-6qrc (OSV record GHSA-mhf7-xp6r-6qrc lists affected ranges: Packagist livewire/livewire >=4.3.0 <4.4.8 (fixed))
- Verified: https://github.com/advisories/GHSA-mhf7-xp6r-6qrc (GitHub-reviewed advisory GHSA-mhf7-xp6r-6qrc lists affected ranges: Packagist livewire/livewire >=4.3.0 <4.4.8)

Commands are suggestions: review each one before running it.

Loading voting…