Skip to content

← Actionable
Critical, CVSS 9.8amended

Critical severity vulnerability that affects event-stream and flatmap-stream

GHSA-mh6f-8j2x-4483

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm flatmap-stream

    Affected
    every version
    Fixed in
    no fixed version recorded
  • npm event-stream

    Affected
    >= 3.3.6, <= 3.3.6
    Fixed in
    4.0.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

The NPM package flatmap-stream is considered malicious. A malicious actor added this package as a dependency to the NPM event-stream package in version 3.3.6. Users of event-stream are encouraged to downgrade to the last non-malicious version, 3.3.4, or upgrade to the latest 4.x version. Users of flatmap-stream are encouraged to remove the dependency entirely.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-mh6f-8j2x-4483

  2. Revision 1 · created ·

    Published from osv record GHSA-mh6f-8j2x-4483

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-mh6f-8j2x-4483

Advisory: Critical severity vulnerability that affects event-stream and flatmap-stream
IDs: GHSA-mh6f-8j2x-4483
Record: https://patchnext.com/advisories/ghsa-mh6f-8j2x-4483 (revision 2, source checked 26 Oct 2026, 12:16 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: event-stream 4.0.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm flatmap-stream: affected every version
- npm event-stream: affected >= 3.3.6, <= 3.3.6; fixed in 4.0.0

## Suggested inspection (read-only)
- `npm ls flatmap-stream --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.
- `npm ls event-stream --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on flatmap-stream, event-stream.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-mh6f-8j2x-4483 (OSV record GHSA-mh6f-8j2x-4483 lists affected ranges: npm event-stream >=3.3.6 =0)
- Verified: https://github.com/advisories/GHSA-mh6f-8j2x-4483 (GitHub-reviewed advisory GHSA-mh6f-8j2x-4483 lists affected ranges: npm event-stream >=3.3.6 =0)

Commands are suggestions: review each one before running it.

Loading voting…