Skip to content

← Actionable
Unrated

SQLite3 addresses vulnerability in packaged version of libsqlite

GHSA-mgvv-5mxp-xq67

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (sqlite3 1.5.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • RubyGems sqlite3

    Affected
    >= 1.5.0, <= 1.5.0
    Fixed in
    1.5.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Summary The rubygem sqlite3 v1.5.1 upgrades the packaged version of libsqlite from v3.39.3 to v3.39.4. libsqlite v3.39.4 addresses a vulnerability described as follows in the release notification: Version 3.39.4 is a minimal patch against the prior release that addresses issues found since the prior release. In particular, a potential vulnerability in the FTS3 extension has been fixed, so this should be considered a security update. In order to exploit the vulnerability, an attacker must have full SQL access and must be able to construct a corrupt database with over 2GB of FTS3 content. The problem arises from a 32-bit signed integer overflow. This vulnerability has not been assigned a CVE and does not have a severity declared. Please note that this advisory only applies to the sqlite3 gem v1.5.0, and only if the packaged libsqlite is being used. If you've overridden defaults at installation time to use system libraries instead of packaged libraries, you should instead pay attention…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-mgvv-5mxp-xq67

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-mgvv-5mxp-xq67

Advisory: SQLite3 addresses vulnerability in packaged version of libsqlite
IDs: GHSA-mgvv-5mxp-xq67
Record: https://patchnext.com/advisories/ghsa-mgvv-5mxp-xq67 (revision 1, source checked 26 Oct 2026, 15:43 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: sqlite3 1.5.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems sqlite3: affected >= 1.5.0, <= 1.5.0; fixed in 1.5.1

## Suggested inspection (read-only)
- RubyGems sqlite3: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on sqlite3.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-mgvv-5mxp-xq67 (GitHub-reviewed advisory GHSA-mgvv-5mxp-xq67 lists affected ranges: RubyGems sqlite3 >=1.5.0 <=1.5.0)

Commands are suggestions: review each one before running it.

Loading voting…