Skip to content

← Actionable
Medium, CVSS 6.6amended

PRoot-Distro has Path Traversal in proot-distro copy — Arbitrary Read, Write, and Persistent Code Execution Outside Container Rootfs

GHSA-mfr4-mq8w-vmg6

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (proot-distro 5.1.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.6 · CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:N
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

<html<head</head<body<h1Path Traversal in <codeproot-distro copy</code — Arbitrary Read, Write, and Persistent Code Execution Outside Container Rootfs</h1 <h2Repository</h2 <phttps://github.com/termux/proot-distro</p <p<strongMaintainer:</strong @sylirre</p <hr <h2Affected Component</h2 <ul <li<strongPackage:</strong proot-distro</li <li<strongAffected command:</strong <codecopy</code</li <li<strongAttack surface:</strong Host-side Termux CLI — this is not a guest distro shell issue</li <li<strongVulnerability type:</strong Path Traversal (CWE-22)</li </ul <hr <h2Affected Versions</h2 Component | Version -- | -- proot-distro | 4.38.0 (initially discovered), 5.0.2 (confirmed still affected — tested on 2026-05-19) Test distro | Ubuntu 25.10 "Questing Quokka" (ubuntu alias) Architecture | aarch64 Device | Samsung A23 Package source | https://packages-cf.termux.dev/apt/termux-main stable/main aarch64 <hr <h2Proof of Concept</h2 <pAll tests were performed using only self-owned files and…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-mfr4-mq8w-vmg6

  2. Revision 1 · created ·

    Published from osv record GHSA-mfr4-mq8w-vmg6

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-mfr4-mq8w-vmg6

Advisory: PRoot-Distro has Path Traversal in proot-distro copy — Arbitrary Read, Write, and Persistent Code Execution Outside Container Rootfs
IDs: GHSA-mfr4-mq8w-vmg6
Record: https://patchnext.com/advisories/ghsa-mfr4-mq8w-vmg6 (revision 2, source checked 26 Oct 2026, 13:49 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: proot-distro 5.1.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI proot-distro: affected < 5.1.0; fixed in 5.1.0

## Suggested inspection (read-only)
- `python -m pip show proot-distro`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on proot-distro.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-mfr4-mq8w-vmg6 (OSV record GHSA-mfr4-mq8w-vmg6 lists affected ranges: PyPI proot-distro >=0 <5.1.0 (fixed))
- Verified: https://github.com/advisories/GHSA-mfr4-mq8w-vmg6 (GitHub-reviewed advisory GHSA-mfr4-mq8w-vmg6 lists affected ranges: PyPI proot-distro >=0 <5.1.0)

Commands are suggestions: review each one before running it.

Loading voting…