Skip to content

← Actionable
Unrated

Apache Log4j Remote Code Execution

GHSA-mf4f-j588-5xm8

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.opencastproject:opencast-common 10.6, 9.10), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
No dated EPSS signal available.
Source description

As published by the source; long descriptions are shortened.

Impact Opencast uses an Apache Log4j2 version which, combined with older JDK versions, can be used for remote code execution attacks which have been found to be actively exploited. Apache Log4j2 <=2.14.1 JNDI features is not sufficiently protected. An attacker who can control log messages or log message parameters can execute arbitrary code when message lookup substitution is enabled. Who is affected - Opencast before 9.10 or 10.6 are affected - Log4j version: all 2.x versions before 2.15.0 are affected Patches The issue has been fixed in Opencast 9.10 and 10.6. Workarounds The vulnerability can be mitigated by setting system property log4j2.formatMsgNoLookups to true. References - Opencast pull request mitigating the vulnerability - CVE-2021-44228 Detail - Analysis and Remediation Guidance to the Log4j Zero-Day RCE (CVE-2021-44228) Vulnerability - VE-2021-44228 – Log4j 2 Vulnerability Analysis For more information If you have any questions or comments about this advisory: Open an…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-mf4f-j588-5xm8

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: GHSA-mf4f-j588-5xm8

Advisory: Apache Log4j Remote Code Execution
IDs: GHSA-mf4f-j588-5xm8
Record: https://patchnext.com/advisories/ghsa-mf4f-j588-5xm8 (revision 1, source checked 26 Oct 2026, 15:53 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.opencastproject:opencast-common 10.6, 9.10. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.opencastproject:opencast-common: affected < 9.10; >= 10.0, < 10.6; fixed in 9.10, 10.6

## Suggested inspection (read-only)
- Maven org.opencastproject:opencast-common: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.opencastproject:opencast-common.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-mf4f-j588-5xm8 (GitHub-reviewed advisory GHSA-mf4f-j588-5xm8 lists affected ranges: Maven org.opencastproject:opencast-common >=0 =10.0 <10.6)

Commands are suggestions: review each one before running it.

Loading voting…